Joomla administrator sections times out when trying to delete records in components

Hi,
I have spent weeks trying to find a solution to this issue. Basically Joomla administrator maintenance (deletion of records from tables) has become near impossible with Cloudflare enabled.

I regularly need to delete records on mass from various components. I used to be able to select 100+ records at any one time and delete them without problem, now it seems to crash if I select 6+ records and shows the Cloudflare timeout error.

I tried installing the mod_cloudflare as suggested in your getting started with Joomla article but it broke my site so had to remove it. I have also tried creating page rules to ignore all administrator areas of my site - it doesn’t do anything.

What do I have to do to get cloudflare with my Joomla administration? I basically don’t wnt cloudflare doing anything in the administrator area.

Any help/advice would be greatly appreciated

How many seconds is this taking? Can you post a screenshot of that error?

mod_cloudflare only passes along the visitor’s IP address and shouldn’t have anything to do with timeouts.

Hi,

it takes over 1.5 minutes to try delete 18 rows and then produces this error:

Error 524 Ray ID: 5011d024d8b8dbef • 2019-08-04 16:14:08 UTC

A timeout occurred

That’s the 100 second timeout:

A workaround would be to add your server’s IP address to your computer’s Hosts file so you don’t go through Cloudflare.

Yes you are right.

Is there any guidance on how to add the IP address to computer’s host files? Do you mean in Chrome?

Hi sdayman,

thanks for your advice. I followed those instructions, cleared browser cache and still the cloudflare error. I tried it in Chrome and Microsoft Edge. Also found these instructions which are basically the same as you provided:

https://documentation.cpanel.net/display/CKB/How+to+Modify+Your+Hosts+File

I did also try adding pagerules to ignore the Administrator area as follows:
mysite/administrator/
Disable security, rocketloader off, bypass cache, Browser TTL cache 4 hours, always online off

Nothing works :frowning:

No Page Rule is going to bypass the 100 second rule. On my Mac, the local Hosts files works well. Dunno why Windows is being difficult. Maybe there’s a Windows user here who can help.

Hi, Can you please explain this solution. I too need this type of solution for 524 timeout error.