Jetpack / WooCommerce connection issues

I have set up a fresh instance of WordPress on my subdomain with the intention of setting up a store with Woo Commerce — https://shop.hellocorey.com — but Jetpack and Woo Commerce are having issues connecting:

Jetpack: Jetpack Dashboard was unable to properly communicate with your
website. Please check your website’s error logs to see what’s wrong.

Woo Commerce: There was an error getting your inbox. Please try again.

I have actioned all the troubleshooting guides I can find.

  • Configured Cloudflare using Jetpack guide
  • Whitelisted Jetpack’s IP range
  • Jetpack debug says everything is fine
  • Site health is currently GOOD with no critical issues.
  • GoDaddy has confirmed the xmlrpc.php isn’t blocked.

As a test, I set up a WP instance with WooCommerce, Jetpack and no SSL and there are no issues at all so I can conclude the problem lies somewhere with the Cloudflare set up.

This is well outside my knowledge, so I am well and truly stuck. Any help would be appreciated. Thanks.

UPDATE

I’ve been speaking with Jetpack engineers on this WP support thread and they have identified the following issues:

When I run a diagnostic test on your Jetpack connection, I get the following error:
cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes received.

This usually means that your web host is blocking some connections Jetpack needs in order to work correctly. In fact, I can also see a 524 Origin Time-out error thrown by Cloudflare when trying to load your xmlrpc.php page.

Cloudflare shouldn’t throw a 524 until after 100 seconds. But certainly if Jetpack only waits 30 seconds, it’s the same problem regardless of long it takes to time out.

Thanks @sdayman I’ll look into this further.

Sila rujuk kepada “Community Tip” di bawah:

UPDATE

Okay, so I have done a lot of testing and research and I’m 99% sure Cloudflare is the issue.

First I tried disabling CF on shop.hellocorey.com but it just makes the primary and sub-domains inaccessible entirely. I’m sure I could fix this to test, but it’s not worth the trouble. Instead however, I just added CF dns to the test instance and coreysilva.com and the same exact problems occurred.

There are 2 areas which I think are causing the issues:

  1. WP0002 rule
    This is apparently disabled by default, but there’s no way to know without at least a Pro plan.

  2. Caching Static HTML with WordPress/WooCommerce
    Which requires the ‘Bypass Cache on Cookie rule’ is only available in Business/Enterprise level plans

So, I’ve concluded that it’s not possible for me to set up WordPress with WooCommerce/JetPack with a Cloudflare free plan — with my current set up at least.

For our Novellhost customers, we don’t recommend Jetpack and never Godaddy for they make things very difficult with their interface. Just an opinion. If you need help let me know. Hope that helps.

Thanks for chiming in. Unfortunately, most users here don’t have access to the DM system.

No worries thank you for the heads-up

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.