Javascript is broken with the cloudfare cache

#1

When I switch to the development mode the website works with the js animation works correctly (see alpha.kleros.io/faq ) but I switch to off this mode it does not working.

I have this error in the console:

Uncaught Invariant Violation: Minified React error #32; visit http://facebook.github.io/react/docs/error-decoder.html?invariant=32&args[]=2 for the full message or use the non-minified dev environment for full errors and additional helpful warnings.

For info I tried to disable the js minification and rocket loader but I have already this error.

Any idea?

#2

Did you also purge the cache?

#3

Yes I tried.

#4

The file is https://alpha.kleros.io/commons-5db12d421e1b6e39ea81.js, right?

That file still seems to be minified. Considering you purged the cache and disabled minification I’d assume at this point that comes from your server. Check if your server minifies it and if that could be the issue.

#5

I did not come from my server because when I use generate url from netlify it works when it’s the url set up with cloudfare it does not working.
I found a solution I disable speed > html and it works.
That’s not perfect but it’s ok.

#6

That would hint at the HTML minification being the issue.

#7

yes because now it works
for info my env is: gatsby (react) + netlify

closed #8

This topic was automatically closed after 14 days. New replies are no longer allowed.