Javascript Captcha Failing


The Javascript Captcha Challenge is failing again on my website.

Here is the ticket I created last week: Javascript Challenge Shows HTML Twice

It seems to be basically the same thing. I am being redirected over and over again to & amp ; & amp ; & amp ; urls and the _cf_chl_f_tk keeps getting adding over and over and over and over.

There is no double DIV tags inside of the HEADER element this time, but it is still erroring somewhere and causing the page to redirect incorrectly with & amp ; & amp ; & amp ; (it will do 100 of them if I let the browser sit).

Here is the HTML I am receiving that is failing: Checking Your Browser

This is like very concerning. Am I really the only person in the world who notices that you can’t get passed the challlenge? I have a ‘ticket’ in from the original issue that replied that it seems to be working. I have replied in there again.

Happy Friday!!!

It started working again over the weekend (I changed nothing again).

Then it started not working again Monday Morning. I like literly “checked it”, it worked. I posted here. I checked another browser (it didn’t work). I tried the same browser and now it’s no longer working.

The page just adds & amp; & amp; & amp; and you can never get through.

How can it just be me out of millions of websites over and over and over this past few weeks? The Default Captcha does not even work.

Shouldn’t it be like, “YOUR BROWSER FAILED. COMPLETE THE CAPTCHA BELOW:” or something? Redirecting over and over until it hits the maximum query length makes every user mad and they can’t ever get through.

It still doesn’t work :frowning:

This is crazy s

The default challenge now works ONLY ON MY .CA WEBSITE. ON MY .COM WEBSITE EVEN THE DEFAULT CHALLENGE FAILS!!! This is on ALL of my devices.

Please escalate this issue and check:

Here is the custom html page I am using in cloudflare: Checking Your Browser

There is something broken with cloudflare!!! ANd it’s been like 2 weeks!!! I have tons of clients on cloudflare and this makes me like :frowning: :frowning: :frowning: :frowning: :frowning:

What the heck is going on! ?! I’ve set the default Capthca page on Cloudflare and I can’t get through: the same exact page and setup works on the other domain

I feel like throwing up over “Cloudflare” now, this issue has taken many many many frustrating hours. The other support just asks me more questions that are unrelated about what a page should do etc, like misses the point: The challenge doesn’t work. Out of everything, it’s like I get picked with a response that makes no sense. :frowning:

:frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning::frowning: :frowning: :frowning: :frowning: :frowning:

Maybe there is major bugs with Cloudflare’s captcha or something, because they released that incident report on my first report about this: Cloudflare Status - Custom Javascript challenge page Issues But now are just silent.

Please tell me something or fix it. LOL!

“This incident is now resolved.
Posted 12 days ago. Aug 06, 2023 - 18:40 UTC”

LIES!!! I am a paying customer. Please correct this issue.

The issue is still happening. does not work works

They are the exact same setup! And there is a BUG in Cloudflare like this: Cloudflare Status - Custom Javascript challenge page Issues

It does a Checkmark, says Pass and then Cloudflare errors and it does a redirect to its self with & amp ; ( there is never a request to my page, there is nothing I can change).

16 Days later…

Just bumping this to say it’s still not working.

I can’t seem to get any help other than statements saying it’s working.

It is not working, there is a bug when you guys have 2 rules or something that can apply to a challenge.

When you goto my website using a Cloud or VPN ip address. I have a rule to challenge all of those requests.

When there is another rule on the /captcha/ page to trigger a challenge, it appears to be breaking your system.

Please investigate.

Visiting from an IP address that doesn’t have the Cloud IP or foreign ip rule does not break the challenge. There is a bad promise or something for more than 1 rule. IDK.

For me

Can you summarize the steps to reproduce, expected outcome, actual outcome?

Are you running the same rules in the same order for both your .ca and .com sites? And, are all other settings (like proxy status, security settings) the same?

One is a paid business account and hte other is free… So there are many more rules in the .com account

When this first all started, The ticket was created here finally: Cloudflare Status - Custom Javascript challenge page Issues

After that, the .ca domain broke about a week later. The .com website would work periodically, on and off (like it was being worked on or something. IDK).

Now it does not work on the .ca or the .com for a custom page or even the default cloudflare pages. (As I type this: it is now working on another device. My Ticket to the Paid Cloudflare Support says something about “Caching” and showed a screen shot of my custom page, but I am using the default challenge page - so I am further confused. It looks to me like it’s some error in promises because of the randomness but I have no clue)

The easiest way that I can reproduce this is by:

  1. Using a Google Cloud IP Address or VPN
  2. Navigating to the website
  3. Get stuck in the Challenge Loop.

When it’s erroring… I am seeing the Checkmark go Green and it says Pass and then it just redirecting to itsself with an additional & amp ; added.

I have a rule setup for any request to /challenge/ to receive the javascript challenge.f

I also have a rule setup to send Cloud Users and Non USA IPS to redirect to /challenge/ (in my system). It checks this by looking for the cookie ‘cf_clearance’. If this cookie does not exist, it redirects back to /captcha/

It has worked perfect for years until I also added in the /captcha/ page that has a rule for ALL requests on /captcha/ to send a challenge.

Once a user has passed the ‘challenge’ in your system, they should be redirected because /challenge/ on my system is nothing but a 302 redirect. But it’s just constantly reloading /captcha/ & amp ; & amp ; etc etc etc.

To better explain I hope:

My website → User does not have ‘cf_clearance’ Cookie && user IS GOOGLE CLOUD → redirect them to /challenge/?returl=/

/challenge/ is completely done by Cloudflare and should redirect the user back to returl’s value (As per my 302 redirect).

My website → User IS GOOGLE CLOUD but has ‘cf_clearance’ Cookie = PASS

This SAME IP, I have ASIN rules setup for… fbut for some reason Cloudflare misses them a TON. So I have to manually Redirect in my system for these missed ips. Why?

BecauseI have a rule that should already serve this user a challenge, but it is not done for some reason. So I created my own ASN lookups and I send them to /challenge/.

Something in this is breaking your system. IDK. That’s all I can come up with.

if asn = google cloud then challenge
if country <> USA then challenge
if request = /captcha/ then challenge

Are the rules I have setup. I redirect also to /captcha/ when I want to when there is no ‘cf_clearance’ cookie.

I started complaining a few days before a global incident here: Cloudflare Status - Custom Javascript challenge page Issues and then still saying it’s not working. Maybe there is something here? It’s been so long LOL.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.