I've tried everything possible and can't load WARP client on Linux Mint

I’ve tried everything possible and can’t load WARP client on Linux Mint. Have been to https:// pkg. cloudflareclient. com/ and followed instructions for Ubuntu

However, when in terminal and after entering “Install
sudo apt-get update && sudo apt-get install cloudflare-warp”

I get this unfortunate result:
“E: The repository ‘pkg. cloudflareclient. com victoria Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘https:// brave-browser-apt-release.s3. brave. com stable InRelease’ doesn’t support architecture ‘i386’”

If you followed the instructions at https://pkg.cloudflareclient.com/ note it mentions specific releases supported for Ubuntu and Debian.

The “lsb_release -cs” command, if you were on one of those, would return one of their releases (unless you were on Ubuntu Lunar, in which case you would be having the same problem, I know because I tried it a few days ago. :slight_smile: )

So yeah, because Mint release is victoria, the command inserted a repo that doesn’t exist into your sources.

Some people might edit the sources list to point to an Ubuntu release, but this is generally a bad idea and can “break” systems, unless Linux Mint specifically has a mapping from their releases to Ubuntu’s and says it’s safe. I have no idea if they do. I’m on MX Linux (not the latest,) and for me “lsb_release -cs” returns bullseye, so it worked.


Copy that. Fingers crossed the release following Victoria will have support…

Thanks for the help!

On a related note, cloudflarewarp-msedge|546x500
following this rabbit down the hole a few days ago (Cloudflare is now powering Microsoft Edge Secure Network) I have access to WARP when running Edge on Linux. Problem with that though is I’m not excited about the MS ID requirement to enable, and not a fan of the Edge Browser.

Wait a minute.

Linux Mint 21.2 (Victoria) is based on Ubuntu Jammy. And besides the main linuxmint repo, for mint-specific stuff, all the other sources point to ubuntu jammy.

The main reason the general advice for “mixing repos” is “DON’T DO IT” is because it is untested, and you can break your system if you don’t do a little research first to determine if it’s “safe,” and have the ability to fix your system if you were wrong.

For instance, you are on a stable release but add a testing repo so you can install “that one app I really need that’s only in testing” and that repo has newer/untested dependency versions that get pulled in when you update, and it breaks your system.

But the cloudflareclient repo contains only one package, cloudflare-warp, which contains only binaries and supporting files, not other dependencies.

So if you edited /etc/apt/sources.list.d/cloudflare-client.list and changed “victoria” to “jammy”…

Your computer would explode.

JUST KIDDING. It should work, but in the small chance it doesn’t, you are on your own. (I just tried it in a VM and was able to install/connect.)

The advice for “mixing repos” should be, as for most things, “DON’T DO IT, unless you know what you are doing and are willing to accept the risk.”

Thanks again!