I've set Cache Everything but HomePage is being served as dynamic

I want the HomePage to be served from CF instead of Dynamic from the origin server. So far no luck for HomePage whereas working fine for internal links.

site techpresident dot com

http://is.am/49p5

For HomePage

http://is.am/49p7

For post pages

is.am/49p8

Spent a lot of time figuring out the issue but my bad luck.

Can you please help with this? Thanks in advance.

Can you post a screenshot of your Page Rules?

1 Like

It was provided without a caption. Please check this URL for Page Rules http://is.am/49p5

Ah, finally got it to load.

Your first rule for Always Use HTTPS matches the home page, so it won’t get to Rule #3

I suggest you use the Always Use HTTPS option in SSL/TLS → Edge Certificates. Then you won’t need that first rule at all.

1 Like

Thanks a lot. You saved me a lot of time. I wish I could ask here earlier. wasted 2 days in this.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.