I've got an error ssl: certificate_verify_failed certificate verify failed

Answer these questions to help the Community help you with Security questions.

What is the domain name?
adxasia.co.id

Have you searched for an answer?
yes

Please share your search results url:

When you tested your domain, what were the results?
ssl: certificate_verify_failed certificate verify failed

Describe the issue you are having:
i’ve got an error ssl: certificate_verify_failed certificate verify failed when hit api to my server

What error message or number are you receiving?
request failed due to connection error: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:600)

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?

Please attach a screenshot of the error:

This seems ok.
https://cf.sjr.org.uk/tools/check?18d7a3cf73874b7dba538c424e0cfc99#connection-server-http

Your domain seems ok, so is this for api.adxasia.co.id?
https://cf.sjr.org.uk/tools/check?5ba1266b0c324b868c8ebe4453fe0bc9#connection-server-https

Your origin server is returning “Internal Server Error”. If that’s not your problem, can you explain in more detail about where you see the certificate issue?

2 Likes

yeah, the error is in api.adxasia.co.id, i got the error message from my raspberry pi client apps


and i dont know why it happens, because it happenned today and never before, but idk what should i check

The Cloudflare edge certificate is ok…
https://cf.sjr.org.uk/tools/check?081ff98fb143425185cb8be414809838#connection-server-https

Are you sure requests are going through Cloudflare and not direct to the server (maybe because you have a local DNS overriding it)?

The edge certificate did update early morning UTC time today. Is your client expecting the certificate to be pinned?

1 Like

after e few trial, i encountered that if i use http for the endpoint, the request was fine, but if i use https the request return certificate_verify_failed, any idea ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.