It works without SSL, but gives a 404 error when SSL is activated

Hello, my website was previously used in a hosting using cpanel, then I moved it to another hosting and used Cloudflare, but my website works without SSL, but when I activate SSL, I get an http 404 error, I could not fix the problem, can you help on the subject?
Website : weepex.com ssl is active now.
thanks.

1 Like

Interesting :thinking:

Is your origin host/server working over 443 port and configured to listen/serve content over HTTPS?

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

3 Likes

hello, first of all thank you. Previously, it was used as opencart in cpanel over cpanel’s own ssl, on a different server, our source machine 443 is running, and now a few other sites are running smoothly on the same server in Cloudflare, SSL/TSL setting is FULLY selected. I’ve checked many things but I can’t seem to solve the problem.

Hello again, when I set the SSL/TSL setting to FLEXIBLE, my site worked securely, but my other websites are running in FULL mode, it worked fine, but it’s an interesting situation. Thanks again.

Looked into mixed content yet?
Some frameworks will auto redirect to 404 when a certain page is loading http instead of https resources. Others might throw 500 Internal server error.
Only bringing this up because most of HTTPS problems i’ve encountered with people were related to mixed content.

1 Like

Big mistake

Still insecure

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.