It seems that Cloudflare does not cache any files?


Today I add my site to Cloudflare. Then update the DNS server, after that, my site can still be accessed without any problem. The problem is, I check each image on my site and their URLs are still on my site, not cached by Cloudflare. It seems that nothing happens after I use Cloudflare.

My site URL is, I check the logo image, the hero image, theirs URLs are:

If these images are cached by Cloudflare, I think they should use a URL from cloudflare instead.


That file has been very much cached by Cloudflare.

$ curl -I -H 'User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0' | grep cache-status
cf-cache-status: HIT

No, that’s not how Cloudflare works. I would recommend to check out, #tutorials, as well as the search for details on that as that topic has been covered endlessly already.

Plus, if you do any WebP conversion on your server, you should stop doing this as well, as this will create problems with browsers which do not support it. The search has more on that too.

Hi, @sandro ,

Thank you very much. I find article Understanding Cloudflare's CDN – Cloudflare Help Center explaining this. THe main reason of my question is that is the document said “Cloudflare does not require an extra CDN subdomain”. But in reallife, I notice many sites, such as using cloudlflare and I can see it is loading resources from a cloudflare domain.

As for the webp image, I am using WP Rocket & Imagify and it will use the original png image as a fallback when it generating the webp image. So I think that will be fine?

That’s precisely how it works. Cloudflare is not really a CDN to begin with.

I am not familiar with Upwork, but their main page at least does not load anything from Cloudflare domains. Also keep in mind, there are other proper CDNs which are actually backed by Cloudflare and such resources could be embedded as well.

No, because if you cache a WebP file that will be served to everyone and will be an issue if the browser does not support WebP. You best disable it on your server and use Polish if you still want to serve WebP.

Hi, @sandro ,

Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.