It looks like your domain is not provisioned with Cloudflare

I am getting this error while integrating Cloudflare WordPress Plugin "
It looks like your domain kräftsmen.com is not provisioned with Cloudflare" what should I do?

Is it because there’s special characters in the domain name @yevgen?

Are you sure that’s the issue ? and what’s the solution?

This is why I tagged @yevgen. I’m not a Cloudflare employee, and I would like to get an answer too.

ok thanks. Waiting for your reply @yevgen

Could you please raise a support ticket for this and post id # here, it will expedite the process. For some reason we can’t load all the necessary data into API for some reason.

Did you login using Global Key or Cloudlfare token for WordPress?

1 Like

Thanks, @yevgen for your reply. Here is the support ticket Id I opened 2 tickets Ids are (#2142269, #2141737). I login using Global Key for Wordpress.

@yevgen Please help out brother still not resolved.

I merged your tickets @hammad.arefeen into 2141737, please use that one to communicate with Support.

As per the recent update on the ticket, the site is active on Cloudflare, are you still encountering any issues?

Hi Cloonan thanks for reply. My site is still performing the same as previous nothing changes and moreover listed issues are still there:

  1. Wordpress Plugin showing the same message "
    It looks like your domain kräftsmen.com is not provisioned with Cloudflare" Screenshot attached.

  2. Please check on my site any product picture URL it’s the same as previous and loading time also very slow no changes. Screenshot attached.

  3. Why is my Cloudflare dashboard in DNS tab it’s showing this message:

" A few more steps are required to complete your setup.

Add an A, AAAA, or CNAME record for www so that www.kräftsmen.com will resolve.
Add an A, AAAA, or CNAME record for your root domain so that kräftsmen.com will resolve.
Add an MX record for your root domain so that mail can reach @ kräftsmen.com addresses."

I believe there’s some issue Please recheck thanks.

1 Like

Not sure why you’re seeing that, in our control panel, I do show it as active.

Can you run some tests and share the results? If you run the speed tests, pause cloudflare and re-run, do you see a difference in performance? I tested here:

https://developers.google.com/speed/pagespeed/insights/?url=xn--krftsmen-1za.com

That has been talked about a lot on this site, Search results for '"Add an A, AAAA, or CNAME record for www so that"' - Cloudflare Community

In particular this post links to a tutorial on how to add those missing records, Add an A, AAAA, or CNAME record for www so that *websitelink* will resolve. I noticed you have an MX record (or two?) called www, you may also want to take a look at the #tutorials on troubleshooting emails for how to set up your MX record, Email Troubleshooting

:man_shrugging: turns to :man_facepalming: after following site advice to :search:

My :search: found a couple of threads related to the plugin. The second topic was solved with

Plugin Discussions

I just Uninstall and Reinstall the plugin still getting the same error/message can’t do anything. What’s the problem?

I have tested both with Cloudflare and Without please check the results. There’s a very little difference although it’s faster with Cloudflare but I want it to load faster what to do here?




Does this cause any problem to site? and should I have to do any cache purge like that sorry I didn’t know much about Cloudflare I am completely new so please guide me thanks.

Hi, @cloonan please can you reply faster as we are in the launching phase of our website if this issue couldn’t be handled or is there no solution for it then I have to look for another CDN that works properly. Thanks

The lack of a www record means www.example.com won’t work, but example.com will. The #tutorials covers how to add the records.

I’d start by working through the top issues that the speed tests report, you need that diagnostic feedback to point out where the site is having issues. There are some very good #performance #tutorials to consult, Performance Tutorials - Google PageSpeed & Webpagetest.org

I have seen the tutorial already I know how to add, but what to add that I don’t know. Please at least review my screenshots I presume all the records are added already but as you’re saying www.example.com will not work so what record should I have to add? I have attached both details of Cloudflare and my Hosting DNS records please let me know what to add now.

They are in place and you can access the site with www or without, ssl is in active and the site loads with https.

Yes the official WordPress Cloudflare Plugin. I have reinstall it but no success same issue. Please if you can resolve this would be great as it’s easy for me to do things from WordPress as I am not familiar with Cloudflare platform. Thanks