.IT Domain name servers not changing

Hello, I bought my .it domain on a italian prodvider (register.it), I transfered it to Cloudflare and then changed back the name servers of the prodvider by error, I tried to move it to Cloudflare again but as I’ve read in this article it’s not possibile due some errors with the Italian register
bitname.it/blog/cloudflare_problemi_dns_punto_it (When someone changes the nameservers from the original nameserver to some nameservers that have been already used in the past, the changes won’t come)

Does anyone know how can I contact Cloudflare’s support or anyone know how to fix this issue? Thank you

.it typically validates the nameservers and there are usually issues if you already had the domain on another Cloudflare account.

Which domain is it and which nameservers should you use?

The domain is armisa .it and i should change the name servers from register .it’s nameserver to adi.ns.Cloudflare .com and agustin.ns.Cloudflare .com (register .it asks the servers ip for some reasons)

ps: sorry for putting a space beetween .it and .com

That should work fine, even according to the Italian registry. Have you tried assigning the nameservers?

You do have DNSSEC on right now however, turn that off at your registrar before changing nameservers.

Also, your site is not working on HTTPS. You need to fix that as well before you use Cloudflare.

Yes, my website is maintained from me and my friend, it’s a radio and we had some issues and my friend (who owns the domain) changed the Cloudflare’s ns to register.it’s ns and made a dumb maintentance page and it’s currently hosted on register.it default hosting, it’ doesnt allow ssl.

You need to fix SSL first, otherwise that won’t work on Cloudflare.

Do you know the ip of adi.ns.Cloudflare. com and agustin.ns.Cloudflare. com by any chance?

Please check out #tutorial for that as there is an article for that.

But for now you should really fix the site first, otherwise that all won’t work.

Ok thank you, I’ll take some time to fix everything and I’ll start the topic again in some minutes, thank you for now!

If you need a certificate - https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/origin

Thank you, I’m already using lets encrypt

That will work as well.

The steps to get it working

  1. Fix SSL
  2. Drop DNSSEC on your registrar’s side
  3. Make sure the correct IP address is on Cloudflare
  4. Change the nameserver

I would stick to exactly that order, otherwise there may be issues.

I got it working, it was just a question of time I guess or something fixed it self.

Thank you, happy new year!

I am not entirely sure, as your server still does not have a certificate. That also suggests you have a legacy encryption mode on Cloudflare. Overall you will still have an insecure site.

Hm, it’s working fine for me and my friend, Cloudflare has enabled the certificate and we aren’t getting any errors like this

Well, you did not fix the certificate, that was the first step I mentioned, before you should have done anything else.

At this point you should pause Cloudflare and fix the server. Your site is not secure.

My server is using a certificate that is being processed from nginx, I’ve updated the servers a few minutes ago so it’s probably just returning the ssl certificate error due the dns propagation being slowly, as you can see in the screenshot, it says that it’s secure.


s

Can you post a screenshot of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls?