It doesn't load the origin certificate and instead loads the Cloudflare certificate

We installed a Sectigo certificate on our server hosted on AWS. It doesn’t matter if we select the “full” or “full strict” option in the “SSL/TLS” section; it always loads the Google (Cloudflare) certificate and never displays the Sectigo certificate installed on the server. How can I make it display the Sectigo certificate using Cloudflare’s proxy option?

You need to upload the certificate to Cloudflare. Requires a business or enterprise account.

1 Like

Welcome to the Cloudflare Community :logodrop:

The behavior you describe is normal and expected when you are using Cloudflare Universal SSL. If you want to provide your own certificate to visitors while your site is proxied, you need to use a custom certificate which is available on Business and Enterprise plans.

3 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.