Issues with Zero Access with PHP in an access directory

I have Zero Trust Access configured and working in several different ways, but when I try to create a php script that references another php script in the same secure directory to pull a dynamic image (through a php script) it returns a Cloudflare Zero Trust image, indicating that it was denied access.

When I create a stand-alone HTML file in the same directory as the requesting PHP file, I can pull the image without issue.

For the record, I should be allowed to bypass all access restrictions because I’m using WARP zero trust, which I’ve confirmed is working in the past. I’ve also added my real IP, etc. The php file also doesn’t go through outbound hosts, it is directly using the referenced php file such as , I’ve also tried writing the full URL in different ways. I’ve added Cloudflare’s outbound IPs and my server’s IP to the bypass list, but it still doesn’t work.

Any ideas on what I can do? I’ve been forced to temporarily allow access to everyone to the directory so I could continue development, so help would be greatly appreciated!

I tried using service auth and changing CORS settings, to no avail.