Issues with SSL

Please help me i am having issue with my ssl

Here is my domain name: https://www.sirstevemedia.com

i have been using the cloudflare ssl for years now and its been working fine until yesterday, i started seeing my website Showing the “Your connection to this site is not fully secure” at the address bar. (all option is enabled i.e the Https rewrites, Always use https etc)

I am using the ssl Full strict from the cloudflare. I have tried to use other options e.g Full, flexible but its still same. (I have cleared cache severally)

i also ordered for a new certificate and i copied and pasted the private key and the origin server key to my control panel, in which ive waited for 24 hours and its still same. i didnt do any recent changes to my website. i want to know what is causing this? Please help

1 Like

You didn’t post your domain name, but it sure sounds like Mixed Content:

This is my website


I’ve read through the link you gave, I’ve done all of them except number 5. pls where can I locate the “Content Security Policy (CSP)”

It’s definitely Mixed Content. My favorite WordPress headers plugin is https://wordpress.org/plugins/http-headers/
In its Security section you can add a Content Security Policy with the “upgrade insecure requests” option.

1 Like

Will i have to keep this plugin on my website? I am looking for a solution without adding plugin.

You can fix mixed content by making sure your website is 100% HTTPS. That means the server has an SSL certificate, and you’ve gone through the database to make sure all URLs for your site assets have HTTPS, and Settings -> General shows HTTPS for your domain URLs.

1 Like

Hi, I also have this problem, how can I solve it without installing a plugin. I have the ssl of miservidory and the ssl of cloud flare. Could this affect? and how do I add all the content to https?

I have fixed mine. I noticed my favicon and header image are http:// link instead of the https:// .

This solved mine. You can run through some images especially the ones from your theme settings and make sure all your images there starts with the https://

Regards

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.