Issues with SSL handshake error 525

Answer these questions to help the Community help you with Security questions.

What is the domain name?
cubicservers(.)de is the main one (not attached to a website), having issues with subdomain panel(.)cubicservers(.)de

Have you searched for an answer?

Yes, I’ve searched for multiple solutions but none worked at all.

Describe the issue you are having:

Can’t connect to my websites hosted on my server, have three domains linked to the same server and It’s doing the exact same thing.

What error message or number are you receiving?

Error 525 SSL handshake failed

Was the site working with SSL prior to adding it to Cloudflare?

Yes, the website was working without any issues until today at 5:51 AM.

Have you tried from another browser and/or incognito mode?

I tried from different browsers, including incognito mode and from different networks

Please attach a screenshot of the error:

Does the site work if you change the DNS record from proxied to DNS-only?

Yes, the website works but without https

Make sure it works over HTTPS as well before you reactivate the proxy.

The thing is that it was working without any issue until it randomly stopped working today. I’ve already checked nginx config files, generated new ssl certs and everything but still having the same issue.

If HTTPS doesn’t work when the proxy is disabled, it means your server is misconfigured in some way. You should keep the proxy disabled until it works.

If you disabled the proxy, I could probably tell you where the problem lies as well.

I’m using cloudflare ssl certs, that’s why https wouldn’t work when I set to DNS-only.

It would, just with a warning that the site is unsafe.

But you don’t even get to that warning, the webserver does not respond with any certificate at all. This means the webserver is misconfigured in some way.

* TLSv1.0 (OUT), TLS header, Certificate Status (22):
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* OpenSSL SSL_connect: Connection reset by peer in connection to

I tested the same certificate on a new server and works correctly, will have to check the webserver again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.