Issues with new Warp Client on Mac OS

I have been using the new Mac OS/IOS WARP client for about 2 days now with my existing Teams account. I have the Teams SSL certificate installed and fully trusted on all of my devices, and there are no other VPN or proxy applications on my network or devices, and the SSL level on my account is set to “Full”. Yet I keep getting errors from the Warp client about SSL certificate errors. Re-setting the encryption keys on each device worked temporarily, but now I cannot even get the WARP client to connect. The debug log does not show anything useful, just a bunch of generic NSURL and NSErrors which do not point to a direct cause. They just essentially say, “unable to connect” or "SSL related error. I have included a copy of the app log, maybe I missed something, I am not sure.

I do see extra devices on my account which were registered but now do not work. How do I remove devices from my Teams account?

I forgot to mention that I have also uninstalled the Warp client and reinstalled it around 3 times. I also reset my iCloud keychain.

Something weird happened though. I connected to a standard VPN client, then connected to WARP and the client connected with no issues at all. But once I disconnected from the standard VPN client and tried to reconnect to Warp, the SSL related errors returned.

My main data center appears to be PDX

Thank you in advance for your assistance