Issues with mailpoet 3 and ssl

#1

After turning cloudflare on, I cant send e-mails with the mailpoet free plan anymore, when I cheg for the ping, it returns with this error: cURL error 35: SSL connect error. Can anyone help me?

The page I need help with: https://mtmassessoriacontabil.com.br/?mailpoet_router&endpoint=cron_daemon&action=ping


I’ve already contacted mail poet 3 and that’s their answer:

Hi there @heronhebling,

We’d recommend reaching out to Cloudflare, it’s most likely an issue with the SSL certificate on the Cloudflare side, similar to this issue here; Error when i added SSL to website

If they can’t help, let us know and we’d be happy to try and assist.

Thanks!

0 Likes

#2

I use Mail Poet 3 and I know it works through Cloudflare.

What’s your SSL setting here? It should be Flexible or Full.

It also sounds like you’re not using their default recommended cron setting of “Visitors to your website.” Is that not working?

0 Likes

#3

-Do you use Mail Poet 3 free plan as sending method?
-My SSL is set to flexible

Mail poet works normal in other websites with smtp sending method, but with the mail poet sending method, it doesn’t.

0 Likes

#4

No, I don’t use Mail Poet for SMTP, as I use Sendgrid for that.

If you’re using Flexible, and curl is running locally, it’s going to have an SSL connect error if it tries to connect directly with your server. You can’t get an SSL certificate on your server for your site?

Or use the SMTP method for this site?

0 Likes

#5

No, I need the cloudflare SSL, and the mail poet sending method… Is there any other way I can fix this problem?

0 Likes

#6

Can anyone help me with this issue?

0 Likes

#7

heeelp, please!

0 Likes

#8

What is the “mail poet sending method”? Your screenshot shows how MailPoet cron is triggered.

Can you show the “Send With” (Enviar com) screen? Go ahead and black out any sensitive information.

0 Likes

closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes