Issues with establishing a connection to domain on first try

Problem started occurring after transfer to Cloudflare, so I think it’s a Cloudflare issue. when pinging my domain that points to a static IP that resolves to a numbered public IP (router creates a static IP) , it takes a second few pings for the link to establish. This happens when connecting via PuTTY, minecraft, even a simple ping test, it fails the first few times. It worked flawlessly at Godaddy, anyone have any insight as to what might be changed here? The CNAME record is set to DNS only on the DNS settings.

Thanks!

Is the CNAME record referring to a record that is also grey-clouded?
It is also likely that you might of had the records orange-clouded at one stage, and that your DNS cache hasn’t been cleared yet.

No, the CNAME record is referring to a NoIP address, which has never touched Cloudflare (worked fine at godaddy) How would I clear the DNS cache? it has been a few months since I switched it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.