Issues w/ Let's Encrypt SSL ACME Challenge via HTTP-01

Hi everyone,

I’ve been diligently working towards getting the HTTP-01 ACME challenge for Let’s Encrypt to work with Cloudflare Free when the domain is proxied.

I’ve succeeded after turning off IPv6 via API, plus having all WAF and Page rules turned off. That’s progress!

In an ideal world, I would like to have my awesome WAF/Page rules in place AND have the ACME challenge succeed without having to deactivate rules or the orange cloud.

To that end, I created a page rule for the ACME challenge.

And now I get a redirect loop error when I try to provision the cert. Even with all rules deactivated except for the ACME challenge page rule.

Fetching http://www.heartbeetfarm.ca/.well-known/acme-challenge/R4BXMGEtu-JAXqI_EO_K7IY6Y4o4k_b2Z6cQVyhFBVk: Redirect loop detected

SSL is set to Full (strict)

What settings or rules should I have in place to give the ACME challenge full access? I have already tried a number of configurations, but it keeps failing.

Thanks for your help with this!

Have you changed your Always use HTTPS setting to off? Would be here: https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates. Also, I would recommend looking into the DNS challenge vs HTTP one.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.