Issues pointing my domain in Cloudflare to my Google Site (new google sites)

I am trying to point my domain to my new website. I am using the new google sites. I keep getting Error 525: SSL Handshake error failed. I have read that there are some issues with Cloudflare and the new Google Sites, mostly because Google Sites has its own SSL, and so does Cloudflare. I had a different address,, working with that site before, so I just want to make sure I have the right settings. My SSL is set to Full, as using Flexible or Off gives the Too Many Redirects error. Is that the correct setting? Does it just take a lot of time to start working? It has been several hours. Help/explanation would be appreciated. Thanks.

1 Like

Hi @nobelpeaceprizeis,

Have you checked whether your site settings match those described in the official documentation?

If you believe the settings are as they should, try taking a look at these related topics:

Or search for other Google Sites topics in the community:

1 Like

I have looked at both of these topics, and yes, I did follow the instructions in the documentation. However, it’s been 24 hours and I’m still having the same issue. I left my SSL setting in Full mode, is that correct?

If Google Sites offers custom SSL certificates for your domain name, use the Full or Full Strict setting.

Have you tried changing SSL to Flexible?

As far as I can tell, Google doesn’t offer anything custom. I’ve tried changing to Flexible, but then I get a too many redirects error.

I previously had the site mapped to and while it initially had the SSL Handshake failed error, after a couple hours it started working. So I’m wondering if I’m just doing something wrong this time around.

Sorry, I do not have experience with Google Sites.

I hope another user knows how to solve your problem.

Let me know if I can help you with anything else.

1 Like

Ok. Thanks for your help though! :slight_smile:

1 Like


Here are the details on the issue you are facing.

Thank you, but frankly I am not super knowledgable about all of this, esp. what is mentioned in that article. Also I am using the new Google Sites, which doesn’t seem to have the option to customize SSL and everything.

Just having a quick read around, and it appears that the new Google Sites does support SSL, however never used it myself. If there an option to enable SSL or upload a custom certificate?!msg%2Fsites%2F78LxArAJxiE%2FhPvIbvzGCQAJ&msgid=hPvIbvzGCQAJ

Not that I have found. I think I read somewhere here on Cloudflare that Google Sites applies its own SSL, and that’s what confuses Cloudflare, but if so, Google doesn’t say anything about it. All I know is that I got it to work with the same site on a subdomain up until yesterday when it was time to migrate it to www.

You need an SSL certificate where your site is hosted for Cloudflare to connect to the server securely, if your SSL mode is Full (strict) then maybe try Full… If not, are you able to contact Google Sites for help with getting SSL on your site?

Oh man, I’ve been on Full this whole time…so I guess that’s not the problem. Okay, I guess I’ll try contacting Google. Thanks for your help!

No, Full means that any certificate will be OK even if it is not issued to your domain. Google may be able to help clear this up!

Sorry for the issues.

72 hours later and the issue is still ongoing. Going to contact Google Sites soon, but if anyone has any idea about what could be going on, the help would be appreciated!

I hope to eventually talk to Google Sites and figure out what’s going on, but since I couldn’t get this working, I switched my domain away from Cloudflare and back to my domain provider’s - now everything works. Google Sites does seem to have its own SSL certificate.

I’m sorry to hear that the issue has not been resolved yet.
Hope you can come back soon and make use of the amazing Cloudflare features.

If you have any updates on this, please consider coming back to this topic and sharing so that other users can also benefit from the response.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.