Issues Adding Custom Domain to Pages already managed by Cloudflare


Asks me to enter the domain,
The domain is already managed by Cloudflare and gives me this error.

What do I need to do to add my domain currently managed by Cloudflare as a custom domain to Workers & Pages?

We aren’t finding the domain. If you have a bunch of zones in the account this problem may happen.

You can use the API (Cloudflare API Documentation) or Terraform to add it

That’s really weird, its here.

Did it ever cross your mind people who might be using cloudflare or specifically the Workers & Pages portion of Cloudflare might not be used to sending out API calls so I’ve been referred to a third party service when my issue is straight forward?

Yes we know not everyone is used to sending API calls out. I’m just telling you the issue and a way to solve it.

It should function properly… My domain is already managed by Cloudflare, why am I having to fix this issue?

The api call does not work either, next suggestion?

I don’t believe as a customer I should have to sign up for a 3rd party service to resolve an issue with a paid service.

I’d need more info. Why didn’t it work?

I fully agree it should work, just bugs happen. I filed a ticket for it earlier today.

I want to add my already managed domain to my Workers & Pages custom domain. This should be simple… I don’t need or want to learn how to send api calls or use a third party service.

I solved the issue, I’m going to give you a -1 star for helpfulness and a 4 star for response time.

I’d thank you but your recommendation did not point me in the right direction.

That’s ok. I wish you’d be at least respectful but hey ho.
At least it’s solved, I’m happy :slight_smile:

I’m not going to go back and forth with you about basic human dignity issues, on “respect” - I’m a paying customer. You’re a company representative. I provided you with feedback.

That is all, this is a business transaction not a weekend outing at the local community park with families.

I was harsh with my feedback because your “solution” was snarky and very grey on what should be done, the entire issue I was describing was over looked and you provided me with a response as " Use a Curl command or Go to this 3rd party site "

If you were to share how you accomplished that, it may be useful to anyone else who winds up in a similar situation.