Issue with the Zero Trust UI where it's deleting the wrong the hostname and not the one selected


There is strange UI issue on the Zero Trust Cloudflare Tunnel UI.

Path # >> Access >> Tunnels >> [Select a Tunnel name] >> Configure >> Public Hostname >> [Go to the last page you have in the list of hostnames you have]

Started recently, where when I select a specific hostname and click delete or edit, it does that to another hostname and not the selected one.

If I delete that hostname, it stays there, and then it deletes another one!

That made me think and wonder how many times I did that without realizing the fact I was editing or deleting anther hostname.

It could be a cache issue on the Cloudflare side, as I tried already three different browsers, and cleared all cached without luck

Please advise!


Do I need to have a paid subscription plan to get support on this issue?

I’ll escalate this post for the attention of the Customer Support Team so they can get back to you here. If you have already contacted Support, please share your ticket number here so that they can track it.

Thanks @domjh , issue still persists and I don’t see any way to fix it. Let me know if you need anything.


We have been unable to recreate the issue you have stated.
When looking the dashboard you are sharing we can see you have paginated Public Hostnames and we do not.

Is this still the case on your dashboard?


I do still have the issue, I have ~59 Public hostname in a tunnel.

Screenshot 2023-01-30 at 1.59.12 PM

The issue happens when I go to the second page

Screenshot 2023-01-30 at 1.59.34 PM

And then when I click on edit or delete, it shows the confirmation prompt window of another public hostname.

Have you tried to create that number of public of hostnames in a single tunnel and go to the second page and test if the issue occurs?


Can you create a support ticket and reply with the ticket number here?

It would also be really helpful if you could include a HAR File in the ticket of the action you are describing.

I would love to add all the supported files including unmasked screenshots, but I can’t create a support ticket unless I have subscription.

Any other ways to get this resolved? Maybe you can a ticket on behalf?

We have a created a ticket on your behalf.
Please respond with the HAR File there.

1 Like

Ticket # #2690463

Done, added more details screenshots and HAR file


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.