Issue with ssl & pending certificate validation

Hello! Having an issue related to the ssl pending status which is ongoing for 24+ hours now.
For some reason my domain stopped working this saturday, returning a dns issue ( I already have a ssl installed on the webserver) and having no clue on how to fix it ( it worked fine previously with ssl and all) I’ve decided to move it over to cloudflare where I already had another domain added and working fine. The problem is that the certificate validation keeps pending, I’ve manually added the txt records on the domain registrar as well (not sure if those were required).

Answer these questions to help the Community help you with Security questions.

What is the domain name?
movilone[dot]es

Have you searched for an answer?
Yes

Please share your search results url:

When you tested your domain, what were the results?
The domain could not load.

What error message or number are you receiving?
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

What steps have you taken to resolve the issue?

  1. Switched the certificate to full strict mode.
  2. Disabled/enabed Universal SSL.
  3. DIsabled/Enabled HSTS

Was the site working with SSL prior to adding it to Cloudflare?
Sort of, as I mentioned above it was working fine with a ssl, but after a while it crashed for some unknown reason so I decided to move it to cloudflare which now returns: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

What are the steps to reproduce the error:

  1. Just check the website domain

Have you tried from another browser and/or incognito mode?
Yes

Please attach a screenshot of the error:

You have a DNSSEC issue as a result of the change of nameservers. Disable DNSSEC at your registrar, or copy the DS records from Cloudflare to your registrar…
https://cf.sjr.org.uk/tools/check?c757679fec884a06873cb1d481d8df24#dns

However, your main issue is this…

You need working SSL before moving to Cloudflare if you want a secure site. Once you have resolved the DNSSEC issue, pause Cloudflare and get your site working directly with SSL before re-enabling Cloudflare again.

Then ensure your SSL/TLS settings are set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.