Issue with SSL Origin Certificates not redirect all requests to https

I want to host my localhost XAMPP server publicly. For that I have taken a custom domain from Hostgator. I have updated that domain in DNS A records and the public IP is also getting configured correctly. I have generated free certificates from the origin server under SSL/TLS and enabled both those certificate “.pem” and “.key” files on port number 444. I changed the default port number to 443.

<VirtualHost *:444>
DocumentRoot “E:/xampp/htdocs/test1”
ServerName mydomain.site
ServerAlias *.mydomain.site

<Directory "E:/xampp/htdocs/test1">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

SSLEngine on
SSLCertificateFile "E:/xampp/apache/ssl/mydomain.site.pem"
SSLCertificateKeyFile "D:/xampp/apache/ssl/mydomain.site.key"

My question is this.

  1. When I open mydomain.site domain, I am getting the error “Connection is not secure”. How to solved this?
  2. When I try to open direct domain mydomain.site it does not open. I want it to open directly from “mydomain.site” without port number. How will this happen?
  3. And if I open from port number “mydomain.site:444” it’s not redirecting with “https”. I have enabled the “Always Use HTTPS” option but still not open with “https”.

Please help me on this issue.

You can’t use port 444 through the Cloudflare proxy. You will need to use your hostname (without a port, as you want anyway) and configure in the origin rules for Cloudflare to use port 444 on your origin for that host.

1 Like

Can you tell me what changes should I make on the mentioned 3 issues?

Can any expert help on this?

You have the answer.

You have already turned on always use HTTPS, you just need to set the origin rules to tell Cloudflare to use port 444 to connect to your origin. Link above.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.