Issue with SSL in mobile Chrome

Hi all

I have an issue with SSL on mobile,

  1. I see the following error in different devices of the same location. Cleared history and checked in incognito

  2. I checked with my partner Ezoic and they don’t see the error

  3. Moreover, I have asked others to check with Apple and Android from different locations in the country and they don’t see the error.

Can this be a local network error?
Any idea how to fix it?



I have checked with Qualys SSL Labs the result is B
This server’s certificate is not trusted by Java trust store (see below for details).
This server supports TLS 1.0 and TLS 1.1. Grade capped to B

The system is Android 8.1.0 with Chrome I checked the browser and seems ok

I have checked the following but I don’t know what to look for.

uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Your opinion would be much appreciated

Universal SSL appears to have onboarded an SSL cert provider which breaks the previously supported older Android devices (My examples are with Android 9).

This has impacted my site too :frowning:

Thanks for your answer @downundercoder I was driving crazy. At least now I know what is it.

The other thing: When you check SSL you get B too?

Are you still encountering this issue @irene? I know there were issues with old versions of Android Cloudflare Status - DNS over TLS does not resolve on and that was widely discussed here, DNS hostname not working on android - #20 by aexsmhels.

I still see the same error message.
What is weird is that I have other sites in Cloudflare and I see them ok with the same mobile device. I only see this issue with one site: surdelsur(.)com
I didn’t enable the private DNS mode.

1 Like

Can you please provide us with your Android/chrome browser version please?

Thanks for your answer

Chrome 113.0.5672.77

I would like to know, is there any update. I have same issue with one of my sites

1 Like

We’re also experiencing this issue.
It seems our certificate now using the authority “GTS CA 2P2” which is not listed on older versions of Android like 7, 8, 9 as a trusted credential.

Has there been any change to Cloudflare’s certificate issuing lately? Our certificate has just been automatically renewed by Cloudflare and we’re facing the issue…

Is it possible to stop using the active Universal SSL to start using the backup? Or generate a new certificate?

We’ve just solved the issue by ordering an Advanced Certificate and selecting “Let’s Encrypt” as a Trusted Authority (it costs US$10).

1 Like

@joao5 @tigran515200
Well it’s weird
I have 3 sites in the same Cloudflare account from the same origin server, however, only one site has this issue.
If it was the certificate the 3 sites should be affected.

how to change ssl certificate from google trust services? Alot of devices cannot reach my site because of the SSL certificate, i know you can pay $10 a month to select your own but is there any other way?

Anything going to be sorted about this?

We have raised the issue and waiting for acknowledgement from Cloudflare. No update yet.


I bet your other sites dont have google trust services as ssl certificate, all my sistes eith google trust services has the issue, other issuers fine

Looks like GTS CA 2P2 cert issued by goo gle service is cause of this issue.
Sites with Cloudflare certs appear to work fine.
Some new cloudflare nameservers started using the new gts ca 2p2 cert?

I didnt change any name servers and google trust was auto added as certificate to alot of sites, hopeful they can reverse this or fix

We also didn’t change any name servers and google trust was auto added as certificate to some of our sites. Those sites are now having issues on some devices.

yup android 7 devices here all now throwing certificate errors at me, those devices were crucial to the operation of my website and are now refused access urgent help greatly appreciated.

My API domain certificate got renewed on 16th MAY 2023 .Now it is giving issues while some of the android users are using it out Mainly in android version 9 it is saying site is not secure .Please help me out how to mitage it out .My domain that is using is