Issue with SOA and parent zone NS giving error with Zoho

Hello to you all, I used to have a website hosted at Bluehost, wich is now hosted at AWS, using Zoho as email service. I use Cloudflare since Bluehost, and at the website all goes just fine, problems are with emails.

I have 5 accounts with the following issues, some of them does receive emails only from another accounts hosted at Bluehost (from another domain of the same company), another accounts receive emails at Zoho, but only from external accounts (not from the accounts hosted at Bluehost), and so on, basically, Zoho services are not working, I tried to delete everything and seting up all, all over again, and the issues are still the same.

I’ve been in contact with Bluehost chat because I thought this was their fault and had this response:

" Please allow me to explain. An SOA record is the Start of Authority for DNS authorizing the best source of information for the pointing of the domain. In this case Cloudflare:

SOA records
ttl: 10,000
email: [email protected] 10,580,042

While I was researching your Cloudfare Name servers, and the SOA as well, there were a few noticeable issues.

The parent zone does not provide glue for nameservers, which will cause delays in resolving your domain name. The following nameserver addresses were not provided by the parent ‘glue’ and had to be looked up individually. A glue record is a term for a record that’s served by a DNS server that’s not authoritative for the zone. This means that the info will loop and grab the most authoritative IP associated to this domain. In your case ours, the last used for your email.

I’ have also found that no MX records exist within the zone causing you not to receive emails on this domain to the IP’s associated to the routing MX (again having it go to the previous authoritative IP* ours)"

It’s kind of stiky to understand, but if you could give me some heads up on how to go on, I will be very pleased.

Thanks a lot!

Glue for name servers isn’t the issue, and you can’t change that, anyway.

It sounds to me like you still have your domain configured at Bluehost, so if someone with a domain at Bluehost tries to send you email, Bluehost still thinks your email is at Bluehost.

Is your domain still in your Bluehost account? Granted, that domain isn’t live, but it can add email confusion there.

The above response said there’s no MX record. What’s the domain?

Thanks for your response!

The domain is, I looked at all the DNS records at Bluehost cPanel but it seems all of them have been deleted. When I first contacted BH, I told them that it may be some record that was cached or something, and that they should at least tell me what to do, but they insisted that’s not the problem and that on their end it’s all fine.

As you are suggesting otherwise, I will check that again, I honestly do not trust Bluehost.

The website linked to the domain it’s hosted at AWS since last december, and I had no problems with the website itself, only with emails.

MX records are set up on Cloudflare, I have 3 of them, as Zoho ask to.

Ok, everything agrees so far. Your MX records are set up for Zoho.

To narrow it down, it sounds like the only problem is email from Bluehost domains don’t get to Pimenton at Zoho. Correct?

If so, then it sounds like your domain still exists in Bluehost’s servers. I’ve had a similar problem with cPanel when I had an unused domain there. Other domains there would send mail to that domain, and it’d stay internal because of this.

Would you happen to still have access to Webmail at Bluehost for Pimenton? If so, see if the missing emails are there.

You got it right, and emails from any random email account, reach Zoho perfectly.

I have access, and the emails that are not reaching Zoho (as we said above), are at webmail, always from another bluehost parked domain…the most reasonable thing is what you said, but since Bluehost was so eager telling me that was not the issue, I tried here.

I will take a look again, hopefully I will get it right.

I’ll post here again if the problem could be solved.

A quick question, maybe you know, if I find something at Bluehost and erase it, should I wait some time for it to take place?, or the issues should be solved inmediatly?.

All evidence points to an internal problem at Bluehost.

If you find remnants of Pimenton and delete it, it should clear up immediately. At least that’s how it worked on my cPanel example. But it could take as long as 48 hours.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.