Issue with record not propagated

Hello,

I am trying to setup a new email sender domain with Hubspot.

I have already setup several in the past without any issue. But recently whenever I add a CNAME record it’s not propagated.

The proxy status is set to DNS ONLY

The domain is paradoxgfoundation.com

Here are the records Hubspto is asking me to setup:

Host: hs1-25367206._domainkey - Data: paradoxfoundation-com.hs04a.dkim.hubspotemail.net.

Host: hs2-25367206._domainkey - Data: paradoxfoundation-com.hs04b.dkim.hubspotemail.net.

I have tried to add without the _domainkey , Right now I have both setup to see if any of them is propagated. But for it’s been several weeks and still not.

Please leet me know if there’s any other informations I should provide to debug this issue.

I am ready to try any other things before having to migrate the domain to a different DNS host.

That domain is not registered. I assume you meant paradoxfoundation.com?

It looks like you have enabled the “Flatten all CNAME records” option in Cloudflare, you need to change that to “Flatten at apex only”.

Indeed, mispelled the domain name. I will edit my post.

It seems like the Flatten at apex option is already activcated (Screenshot)

Oh, I probably had a typo as well then earlier. I can see the correct record now:

dig +short hs1-25367206._domainkey.paradoxfoundation.com
paradoxfoundation-com.hs04a.dkim.hubspotemail.net.

dig +short hs2-25367206._domainkey.paradoxfoundation.com
paradoxfoundation-com.hs04b.dkim.hubspotemail.net.

dig +short hs2-25367206._domainkey.paradoxfoundation.com @8.8.8.8
paradoxfoundation-com.hs04b.dkim.hubspotemail.net.

dig +short hs2-25367206._domainkey.paradoxfoundation.com @wally.ns.cloudflare.com
paradoxfoundation-com.hs04b.dkim.hubspotemail.net.

dig +short hs2-25367206._domainkey.paradoxfoundation.com @karl.ns.cloudflare.com
paradoxfoundation-com.hs04b.dkim.hubspotemail.net.

However, it seems there might be something wrong with Cloudflare’s 1.1.1.1 resolver:

dig hs1-25367206._domainkey.paradoxfoundation.com @1.1.1.1 +short
13.248.169.48
76.223.54.146

dig +short hs2-25367206._domainkey.paradoxfoundation.com @1.1.1.1
13.248.169.48
76.223.54.146

dig hs1-25367206._domainkey.paradoxfoundation.com @1.1.1.1

; <<>> DiG 9.18.18-0ubuntu0.22.04.2-Ubuntu <<>> hs1-25367206._domainkey.paradoxfoundation.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49355
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;hs1-25367206._domainkey.paradoxfoundation.com. IN A

;; ANSWER SECTION:
hs1-25367206._domainkey.paradoxfoundation.com. 3600 IN A 13.248.169.48
hs1-25367206._domainkey.paradoxfoundation.com. 3600 IN A 76.223.54.146

;; Query time: 32 msec
;; SERVER: 1.1.1.1#53(1.1.1.1) (UDP)
;; WHEN: Fri Feb 16 17:15:25 CET 2024
;; MSG SIZE  rcvd: 106

Can you find these IP addresses anywhere in your DNS records? Or better, could you maybe show a screenshot of your DNS records?

dig something._domainkey.paradoxfoundation.com @1.1.1.1 +short
13.248.169.48
76.223.54.146

dig something._domainkey.paradoxfoundation.com @karl.ns.cloudflare.com +short
(nothing)

Here is a screenshot of my DNS for this domain.

I was not able to find these 2 IP addresses in my records of this is the result of the CNAME being flattened ?

Thanks for your help and looking into it

Hi, I’ve just noticed that you created NS records for _domainkey.paradoxfoundation.com:

_domainkey.paradoxfoundation.com. 300 IN NS     ns3.afternic.com.
_domainkey.paradoxfoundation.com. 300 IN NS     ns4.afternic.com.
;; Received 116 bytes from 108.162.193.190#53(karl.ns.cloudflare.com) in 4 ms

You need to delete these if you want to manage your DKIM records in Cloudflare.

1 Like

I will try this, thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.