Issue with Openfire/XMPP Chat Service when Proxy Enabled for subdomain

We are currently experiencing an issue with Cloudflare not allowing certain ports to run on our server. Specifically, we are unable to use ports 9090, 9091, 5222, and 5223, which are essential for the functioning of our XMPP (Openfire) application.

We have attempted various troubleshooting steps, including reviewing our firewall settings and verifying our Cloudflare configuration. However, despite our efforts, we have been unable to resolve the issue. The blocked ports are causing significant disruption to our XMPP service, preventing users from connecting and communicating effectively.

We kindly request your assistance in enabling these ports (9090, 9091, 5222, and 5223) on our Cloudflare configuration. By allowing traffic through these ports, we can ensure seamless communication and provide uninterrupted service to our users. We understand the importance of security measures, and we assure you that our application follows all necessary protocols to ensure a secure environment.

To enable those ports you’d need an Enterprise Spectrum subscription. So best bet would be to contact sales.

1 Like

If an Enterprise plan is not in your budget, you might want to consider moving your XMPP services to a subdomain such as and configuring it :grey: DNS Only.