Issue with Inaccessible Zabbix Web Page After Enabling Cloudflare Proxy

What is the name of the domain?

doubun.cc

What is the issue you’re encountering

I have a machine on DigitalOcean with a firewall set to allow connections only on ports 443 and 22 from specific IP addresses. The connection on port 443 leads to my Zabbix web page. After transferring my domain to Cloudflare and enabling the Cloudflare proxy feature, my website stopped working, even though I was connecting from an IP address on the allowlist. When I disable the proxy, the website works fine again. I tried adding Cloudflare’s IP addresses to the allowlist for ports 80 and 443, but the issue persists. Could you please help me understand what might be causing this issue and suggest possible solutions? I appreciate your assistance. Thank you.

What steps have you taken to resolve the issue?

I added Cloudflare’s IPv4 addresses to the inbound allowlist for ports 80 and 443 on my machine.

What feature, service or problem is this related to?

DNS records

Make sure you add the IPv6 addresses as well if your origin supports IPv6.

1 Like

Make sure that you are restoring visitor IPs if you want to restrict access by connecting IP.

1 Like

This would be a lot easier if you shared the error message you see when opening your website via Cloudflare. “Stopped working” is not a helpful description of the problem.

1 Like

Thank you for your reply. I will pay more attention to this part. I noticed that the status code is 301, and there are continuous redirect requests, causing the browser to display “too many redirects,” but in fact, the redirection is not successful.

I checked my nginx configuration, and only port 80 should be redirected to 443.

Thank you for your reply. I also tried adding IPv6 to my inbound allowlist. Despite adding both rules for ports 80 and 443, it still shows that the webpage cannot function properly and displays “doubun.cc redirected you too many times. Please try deleting your cookies. ERR_TOO_MANY_REDIRECTS.”

99% of the time, this happens because you are using the Flexible SSL setting in Cloudflare. Please change that to Full (strict).

You can see that the error message is even automatically replaced with a link to the possible solutions.

2 Likes

Thank you very much, that’s correct. After I changed the setting to full (strict), I was able to access it normally. Thanks again! :pray:

2 Likes