Issue with gRPC

Hello cloudflare experts,
Need your help, we have a gRPC protocol used in some part of our product, we are facing some issues making it work with WAF, the scenarios is as described below,

  1. We have two APIs hosted in two different AWS accounts

  2. One API will make a POST call (gRPC) to another through public end point

  3. We get below 403 forbidden error when this call is made,
    %v rpc error: code = PermissionDenied desc = Forbidden: HTTP status code 403; transport: missing content-type field

  4. We thought cloudflare is blocking this call so we created a firewall rule to allow (tried allow, bypass both the options) this request,
    for ex:
    Request Method equals POST
    AND
    URI Path contains /v1/createSchema
    Then
    Allow

  5. we are still facing same issue even after creating this rule, i am not sure why this rule is not letting the call go through, even though i see rule status showing number of calls executed by this rule, etc

  6. We tried to enable networ->gRPC, but no luck, we get different error when this is enabled, which is,
    rpc error: code = Unavailable desc = Service Unavailable: HTTP status code 503; transport: received the unexpected content-type “text/plain”

Looking for expert help to resolve this issue, please help

Hi, can someone help here please?

This topic was automatically closed after 30 days. New replies are no longer allowed.