Issue with dedicated SSL cert

Good day, community.

Recently faced an issue with dedicated SSL certificate. Was using it for a long time, but some days ago there was need to add new subdomains. CF described the process as recreating current dedicated certificate with addition of new subdomains, so i did it. As for now, proxying through CF is not working anymore, as it shows “ERR_SSL_VERSION_OR_CIPHER_MISMATCH”.
SSL encryption is full, min TLS version 1.0. No settings were changed during cert recreation.
Hosts are encypted with LetsEncrypt certs, which are all valid, and working w/o proxy.

Also forgot to mention: tried to recreate dedicated certificate several times, waiting for 24hours before and after recreation.

Root domain is working fine with new certificate (y.z), next level subdomains (x.y.z) also, but not (a.x.y.z).

And also receiving certificate transparency notification that dedicated certificate was successfully issued for mentioned domain/subdomains, but still not working.

Raised a ticket to CF, but no answer for a week already, even pinged several times.
Also tried to find some solutions here, but no luck.

It sounds like you did everything right. Please post the Ticket # here.

2 Likes

Good day, sdayman.

Sure, ticket number is: 1971545

1 Like

Thanks. The mods (@cloonan, etc) usually sweep the forums looking for ticket numbers to check on.

2 Likes

Thank you, will wait.

1 Like

Fixed.

I made a mistake - ordered a cert for subdomain.domain.com, but not for *.subdomain.domain.com.

2 Likes