Issue while accessing WordPress Dashboard

Hello, few weeks back I installed cloudflare on my WP website, was working great, https, load speed, everything. Few days back I changed the Theme and a problem popped up :- " Sorry, you are not allowed to access this page." while accessing admin panel. I tried on different devices and was the same.

I contacted my host, GoDaddy, they asked me to change the DNS records back to default and did what they asked for. The issue was resolved but thinking that it might be a one time issue, I reinstalled the CF and the same problem has popped up again.

Does anyone know how do I fix this?

Latest Wordpress version
Theme :- Smart-Mag
Cloudflare plugin installed

What’s the domain?

Is it wp-admin that’s blocked, or wp-login? Right now, it lets me hit wp-admin which redirects to wp-login.

Can you post a screenshot of the error?

I can access wp-login page but when I get to wp-admin it shows error

Screenshot :-

That looks like a restriction set up by your host or site. Do you have some sort of IP address blocker for wp-admin? If the host isn’t restoring visitor IP addresses, then it’s not going to recognize your permitted IP address.

Your choices are to either disable that IP address restriction for wp-admin, or get your host to restore visitor IP address from Cloudflare.

No. There is no such IP address blocker plugin installed

As I said earlier, when I remove CF and change DNS to default , everything works fine

Your screenshot is not a Cloudflare blocking feature. Whatever that is, it’s coming from your server. For whatever reason, it’s not allowing wp-admin connections from Cloudflare. As you said, on the old theme, it was fine. So maybe something in the theme change did this.

How about disabling that Cloudflare plugin?

If that doesn’t work, there are plenty of results of the same error in a Google search.

This topic was automatically closed after 31 days. New replies are no longer allowed.