Issue setting up custom domain on Pages (does not recognize domain already added)

When I try to setup a custom domain on Pages, I am prompted to transfer the DNS.

The iossue is the DNS has already been transferred to Cloudlfare (it’s been set up under the Website tab).

When I try to add the domain, it says “domain already exists”

Any way to get around this?

Can you share the domain?

Sure - icebathlist.com

Which nameservers are assigned to you under DNS → records?

Thanks! Would appreciate any pointers.

I’m afraid those links automatically got replaced for whatever reason.

Can you try to use the preformatted text (Ctrl+e) option? Or just write the name, not the full nameserver.

brenda.ns.cloudflare
lakas.ns.cloudflare

It’s worth baring in mind it was working before, but it looks like I accidentally removed the domain, and re-added it again which gave my new DNS. Fingers crossed can get this solved. Thanks!

Hi,

It seems you have changed you nameservers back to GoDaddy now.

I tried using GoDaddy’s default DNS and re-adding the domain, which I did, however when I try to setup the custom name in “Pages”, it’s still promoting me to transfer the DNS to Cloudflare, which I’ve already done. This is so confusing!

Any ideas I could try to fix this? Thanks.

So if you go to https://dash.cloudflare.com/?to=/:account/:zone/dns/records and select icebathlist.com, it says your nameservers are brenda and lakas? Can you show a screenshot of that?

I just want to make really sure, because I can see that your domain was also added to a Cloudflare account with a different set of nameservers.

Correct:

Can you also show a screenshot of the custom domain tab of your pages project?

And please create a cname record for name cdn.icebathlist.com with your x.pages.dev as the target.

Sure thing. I appreciate you trying to help with this:

Can you please create a support ticket with category “Account” and share your ticket number here?

I’ll bring it to the attention of support.

I submitted the support request. Hopefully we can get this resolved. Thanks.

If you share your ticket number, I can ask support to take a look at it.