Issue Connecting Subdomain to R2 Bucket - Status Shows "Unknown"

Hello Cloudflare Community,

I’m reaching out to seek assistance with an issue I’ve encountered while setting up my Cloudflare R2 storage. I recently created a new bucket in R2 and attempted to connect a subdomain to this bucket. However, despite following the standard configuration steps, the status of the connection in the Cloudflare dashboard is persistently showing as “Unknown.”

Here are the steps I’ve taken:

  1. Created a new R2 bucket.
  2. Attempted to connect the subdomain to the R2 bucket through the Cloudflare dashboard.

Expected Result: The subdomain successfully connects to the R2 bucket with a clear status indication. Actual Result: The connection status remains “Unknown,” with no further information on whether the connection is active, pending, or failed.

Thank you in advance for your help!

1 Like

Hi there,

Are you able to share the domain you are having an issue with connecting the subdomain? I’m happy to take a look.

Curious if you have a support ticket open with Cloudflare regarding this - as it may require us to discuss specifics, which may not be appropriate for this forum.

regards,
Damian

Hello @badi, Greetings of the day.

I’m exactly facing the same. @Damian I must say, this problem is not specific to individuals but most of r2 users are facing.

I’ve existing connected domain, and that is perfectly working fine. But, if we try to add new domains having in same account, with no content or with content in r2; different settings, or CORS Policy enabled/disabled; public or private; no matter what configs I tried, nothing worked; status remain “Unknown” and not Active; while Access to Bucket is “Allowed”.

FYI, While same account has custom domain configured with bucket and fine. Something has to do with new stuff’s.

@badi what solution worked for you, will you please share with rest of community who is facing the same?

Anyone able to figure this out?
I am facing the same issue.