Issue connecting Gmail (G Suite) to Outlook


#1

Hello!

A client isn’t able to connect their Gmail (G Suite) account to their Outlook using IMAP. They’re receiving a “unable to connect to incoming server”.

We’re using Cloudflare for the DNS service (free). I’ve setup the MX records. Will include a picture below. However, nothing is working yet.

We’ve ‘enabled’ IMAP on the Gmail settings, but still no go.

I’ve chatted with Google support (it felt like I was chatting with a robot posing to be a person :confused:), and they said our MX records were correct.

They’re hosted with FlyWheel and their domain is registered with another company, not Google or Cloudflare.

We’ve been stuck on this for more than a week now.

Do you have any advice?


#2

The incoming server for G Suite is completely unrelated to Cloudflare (I assume it’s not even under your domain)… If the MX records are correct then the issue lies elsewhere.


#3

Thanks for the quick reply.

The G Suite is using the clients domain; (ie) [email protected]

Does this change anything?


#4

Nope, that was a given with G Suite.

What do you put in the Outlook settings while configuring IMAP? Also: why not use directly the Google login (may be mobile only)? Or directly mail.google.com?


#5

Also: why not use directly the Google login (may be mobile only)? Or directly mail.google.com?

Client was using them before and wants to keep using them.

They’ve been using the Google instructions (here).

The incoming server for G Suite is completely unrelated to Cloudflare (I assume it’s not even under your domain)…

What did you mean here? I didn’t understand you.


#6

In the Outlook settings for IMAP and SMTP servers you are putting in *. gmail.com, those are completely unrelated to Cloudflare and Cloudflare’s MX settings.


#7

What do you think the issue(s) may be matteo?


#8

Most likely configuration error, check the settings and the ports, the username and password combinations, the IMAP settings on G Suite.

Otherwise talk to the correct support, G Suite’s.


#9

I chatted with Google support, they said the MX records were correct. I really think an issue is with Cloudflare, since the name servers are being managed here.


#10

I am telling you it’s not. I am completely certain of that.

Try another mail client. Use Google’s login option in the mail client, do not add the account via IMAP.

The extent of Cloudflare involment is MX records. Google itself told you they are correct and they would prevent mail delivery, not mailbox connectivity.

You are connecting directly to Google (imap.gmail.com and smtp.gmail.com). You could even delete your domain with all the records and that part would still be working just the same, Cloudflare doesn’t get involved in that.


#11

Appreciate you taking the time to answers my questions and clarify some things.

I just tried to add their email in Mail with Mac without IMAP, no issues, logged in.

I tried doing the same with IMAP and it wouldn’t work.

What about the records for their website, would that effect their email, since it’s @theirdomain.com ?


#12

Absolutely not, I guess IMAP may not be enabled then. Try checking again. Try also IMAP on Apple Mail, just out of curiosity.

Beware of the download limits and the correct confirm that you see in the link you posted before.


#13

Resolved the issue. IMAP working smoothly now.

We needed to change Google security settings (here) and delete MX records from previous host pointing at domain.

Thanks for your inputs matteo.


#14

This didn’t matter actually. The other thing yes.


#15

@FRANKenstien You might find G Suite Sync for Microsoft Outlook helpful.


closed #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.