Issue adding aliases through Cloudflare

So I was told that I could put multiple domains as “addons” or aliases in Cloudflare and they would redirect to the primary domain. I tried to add CNAME but it won’t do it.

For example, the primary domain is ABC.com. I want ABC.net and ABC.org to be aliases to the .com one, so when people try to access through .net or .org they will get the .com one. I do have the Cloudflare NS on .net and .org.

What do I do to best practice this?

That is technically incorrect.

What you can do is add each of those domains to Cloudflare and then configure page rules to redirect to your primary domain.

More on that at Using page rules to perform redirects - courtesy of @domjh

2 Likes

I just did that, and it does not show any results. Just the page “Server Not Found”

Which domain did you add?

This is the domain: kristincavallari.net

Read the article once more carefully. You did not create the DNS records.

I believe I did;

2

Change that redirect to @.

Ok done. It automatically turns into that domain… I guess now just wait for it to take effect…

The redirect seems to work fine now.

Not for me; I still get “server IP cannot be found” after clearing the cache.

Most likely a propagation issue in your case. Just wait a couple of hours until your records expire for your resolver.

I trust you! Thanks so much!!!

:slight_smile: If you switch to a public resolver you should be able to verify it straight away. They are typically faster than ISP resolvers. Alternatively you could try to reboot your router, in case you are using it as resolver.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.