ISP Problem: High Latency with HIGH TTFB ! Workers served from other End of the Globe!

I just checked out the Performance Report in the Dash and saw that some of my pages did
not have good Performance Numbers even they are static Workers Webpages wich should be served
ultra fast by cloudflare using the neares POP Edge as i am even on the PRO Plan.

I loaded each Page now for testing in the Webbrowser and saw that all my Workers are served
from the other End of the Globe instead from the POP neares to me by cloudflare !!!

What the ■■■■ !!!
This was not allways like this !

Something bad happened.
My static Workers Pages are served with a very HIGH Time to the First Byte becouse of this !

Here is a screenshot as a evidence and this numbers are moderate.
I have seen even more bad Numbers …
The Headers show that the Workers are served from LAX and MXP which is on the opposite End of the Globe from where i make the Request.
The workers had to be serverd from Europe and not the USA !!!

Why did this Happened ?
Was not like this before !!!

Looks Like the ■■■■ has broke out at Cloudflare Data Centers in Europe at least.

When i do traceroute my domain crazy things with huge dealy show up …

This must have been going several days now …

So, first of all MXP is in Europe. Secondly I higly doubt Cloudflare will respond from LAX if you do requests from Europe.

Have you actually tried a different ISP? This is something caused by ISPs, not Cloudflare, especialyl in Europe.

Can you also post a traceroute to your website?

2 Likes

All my Workers are served from LAX.
Here is a example of the Header Request

CF-RAY: 5f93f31fddffe7a8-LAX
cf-request-id:06b05647e40000e7a867aca000000001

Before it was Frankfurt or Zurich

Here are traceroutes.
Strangly the routes change nearly every minute.
One time it goes over Frankfurt other time over a Swiss ISP

1 fritz.box (192.168.178.1) 0.503 ms 0.852 ms 1.287 ms
2 80.254.161.230 (80.254.161.230) 8.264 ms 8.255 ms 8.878 ms
3 146.228.3.85 (146.228.3.85) 8.852 ms 9.031 ms 9.561 ms
4 146.228.2.130 (146.228.2.130) 10.515 ms 10.430 ms 10.948 ms
5 146.228.2.58 (146.228.2.58) 38.790 ms 38.781 ms 39.459 ms
6 de-cix-frankfurt.as13335.net (80.81.194.180) 53.039 ms 41.336 ms 35.791 ms
7 * * *
8 198.41.140.28 (198.41.140.28) 132.692 ms 133.057 ms 133.022 ms
9 198.41.140.63 (198.41.140.63) 160.268 ms 198.41.140.3 (198.41.140.3) 148.972 ms 198.41.140.63 (198.41.140.63) 160.947 ms
10 198.41.140.41 (198.41.140.41) 183.245 ms 180.673 ms 198.41.140.7 (198.41.140.7) 162.846 ms
11 198.41.140.60 (198.41.140.60) 209.244 ms * *
12 104.26.6.190 (104.26.6.190) 184.055 ms 184.524 ms 179.346 ms

1 fritz.box (192.168.178.1) 0.640 ms 0.987 ms 1.047 ms
2 80.254.161.230 (80.254.161.230) 10.262 ms 10.481 ms 12.096 ms
3 146.228.3.85 (146.228.3.85) 12.849 ms 10.442 ms 11.819 ms
4 r1glb3.core.init7.net (77.109.134.81) 10.416 ms 12.795 ms 15.582 ms
5 r1zrh10.core.init7.net (77.109.128.115) 15.833 ms 16.832 ms 15.521 ms
6 r2win7.core.init7.net (77.109.128.142) 17.269 ms 7.813 ms 7.675 ms
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 5-180-135-63.init7.net (5.180.135.63) 32.708 ms 32.673 ms 7.972 ms
15 * * *
16 r2mxp1.core.init7.net (5.180.132.215) 27.558 ms 27.764 ms 28.743 ms
17 * * *
18 188.114.100.3 (188.114.100.3) 63.825 ms 63.805 ms 44.653 ms
19 172.67.71.68 (172.67.71.68) 24.113 ms 24.504 ms 24.547 ms

1 fritz.box (192.168.178.1) 0.604 ms 1.812 ms 2.941 ms
2 80.254.161.230 (80.254.161.230) 11.047 ms 11.260 ms 11.239 ms
3 146.228.3.85 (146.228.3.85) 11.373 ms 19.968 ms 19.960 ms
4 146.228.2.130 (146.228.2.130) 12.135 ms 19.943 ms 14.343 ms
5 146.228.2.58 (146.228.2.58) 40.574 ms 43.403 ms 41.276 ms
6 de-cix-frankfurt.as13335.net (80.81.194.180) 49.195 ms 37.489 ms 38.645 ms
7 * * *
8 198.41.140.28 (198.41.140.28) 135.617 ms 137.472 ms 137.448 ms
9 198.41.140.3 (198.41.140.3) 150.092 ms 145.721 ms 146.008 ms
10 198.41.140.7 (198.41.140.7) 162.842 ms 198.41.140.58 (198.41.140.58) 169.055 ms 198.41.140.7 (198.41.140.7) 162.429 ms
11 * 198.41.140.60 (198.41.140.60) 222.227 ms *
12 104.26.6.190 (104.26.6.190) 183.761 ms * 179.850 ms

I see. Your ISP seems to be AS1836. But it also seems strange, as you are entering Cloudflare’s network in DE-CIX in Frankfurt. It may be an issue with their private backbone.

I would probably try and open a support ticket. Maybe post the ticket number here so that the staff can follow it from here.

Also, calling @cloonan. He is in it’s Thanksgiving weekend, but whoe knows. @adspedia as backup :slight_smile:

4 Likes

Hi Matteo !

Thank you very much for your fast Replys and Support.

I checked my Cloudflare Website last Days using VPN as a alternative and did not experience
any problems.

The Website lads fast when using a different ISP over VPN.

Yes my ISP is Green AS1836.
Will do more research and wrote back.

What i could imagine is that it is maybe related to ARGO !
I have Argo enabled and Argo Routes Traffic.
In my Dash LAX is one of the main Hot Spots to reduce Latency.

I guess when using VPN on my Webserver that has ARGO enabled for this IP that it may try to redirect traffic ?

Will have to check with different Dynamic IP from ISP and see if it is just realted to the static IP for the Server that ARGO guess use too.

For the moment this is Isolated only to my ISP as it looks like.
When Using the VPN my latency is only 20 milli seconds altough it uses not the nearest City as supposed in my case Zurich when using Swiss IP but use Milano Italy MXP.

Asking me Why MXP all the Time …
Still happy with very low Latency for my Workers over VPN:

Hey @seoworks!
Yes, as @matteo suggested, please open a support ticket with our team so they can investigate this.

3 Likes

Thank you adspedia for help.

Wanted wait till i have more information and the Weekend is over so you all do not need work over the hollidays and weekend.

As requested by you i opened now a ticket.
Ticket Number is: 2034381

If you need me to do more let me know.

Have a great Day.
Best regards.

2 Likes

Our team will get on that as soon as possible. Thanks!

3 Likes

I just want report that i had a total Internet Blackout right at Midnight 1 hour ago and could not access any website anymore.

When loged into my Router i saw that the DSL Connection was active and running without any Problems.

So everything pointed toward the fact that i was using Cloudflare DNS 1.1.1.1 to resolve the domain names in my Router.

I deactivated to use Cloudflare 1.1.1.1 in my router as my DNS resolver and enabled back the standard DNS Resolvers of my ISP.

Internet started worked again instant without any reboot or dsl reconnect.

Hi all.

After i disabled the Cloudflare DNS in my router and waited some hours
the problems i had with the workers served from the other end of the globe disappeared.

It looks like this was a isolated problem to my setup i had with
DNS Resolve Service 1.1.1.1 in my router set in combination with
ARGO for the same IP address and a VPN for Web browsing.

With the ISP DNS servers in my Router now all workers are served ultra fast as expected.
So problem is solved.

Pay attention not to use Cloudflare DNS Service in combination with ARGO on the same server with a vpn as it will then rerout the vpn traffic it looks like.

Thanks for the Help.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.