Займ.я.рус is not a registered domain

Hey! Immediately I apologize for my English - this is a google translator.

The crux of the problem: I cannot add a new site to Cloudflare. His address is “займ.я.рус”. This is a Russian site. When trying to add a site, the message “is not a registered domain” is displayed. I would like to understand what the problem is?

The “я.рус” domain is listed at https://publicsuffix.org/list/public_suffix_list.dat, which, as I understand it, Cloudflare is targeting.

Is it because the domain has two parts? Or is it written in Cyrillic? Please tell me how to solve this problem. I will be glad to any of your thoughts.

Have you tried adding it with punycode?

And here’s some more info that usually trips people up. (short version: their domain doesn’t currently resolve.)


Thank you for the answer.

Regarding Punycode, I forgot to mention. I tried this option right away - it didn’t help :pensive:
When trying to add a domain using punycode, the following message is displayed:
We were unable to identify xn - 80anhm.xn - 41a.xn - p1acf as a registered domain. Please ensure you are providing the root domain and not any subdomains (e.g., example.com, not subdomain.example.com)

Regarding the second part of your message. I did not quite understand. But just in case, I changed the DNS records at the registrar. I entered the server names from Cloudflare there (as on my other sites, also working through Cloudflare). Nothing has changed - everything is also “is not a registered domain” :roll_eyes:

1 Like

That will be most likely it. Cloudflare does support IDNs, but occasionally there are issues.

It’s probably best to open a support ticket, link to this thread, and reply twice to it so that is actually does not get closed.

1 Like

Are you able to add the domain via our API?



Unfortunately, this turned out to be beyond my understanding :frowning_face_with_open_mouth:
Just reading the documentation was not enough to understand the API from scratch.

Probably, it will be easier to abandon the idea of using the domain in Cyrillic letters and buy some other one.

Thank you all for your participation.

The issue is actually not with Cyrillic characters, but with the .я.рус SLD (президент.рф for example works just fine).

I escalated it a few times and @Chris_M had a proper look at it and it seems as if there was an issue with that SLD on Cloudflare right now. No details though I am afraid.

No need to try via the API, doesn’t work either.

1 Like

Thank you. Could you please submit a ticket and let us know? We’ll want to try adding it manually on our end next.

1 Like

I created a support ticket, hoping that maybe my problem still has a simple solution.

My ticket number is: 2246501.

Also, according to the instructions from the letter, I mention {redacted} to bring my message to the attention of specialists.

1 Like

I am afraid that’s pretty pointless, everyone who can remotely do anything is already here.

The issue right now really is that Cloudflare has an issue with .я.рус which they need to fix.


We’re seeing this as an issue with the .pyc registrar where it’s not always responding. Our suggestion would be to next reach out to the domain registrar to confirm that they are not seeing issues.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.