Is my DNS configuration correct?

I’m trying to configure my DNS for my subdomain, staging.ewagers.co. After a lot of research, it seems I just need to set the A name record from staging to my IP address. However, it doesn’t seem to be working:

Type. Name. Content
A. ewagers.co [my prod site IP]
A. staging [my staging site IP]

When I ping my staging site IP, I am able to get responses back. However, when I visit my staging.ewagers.co site on Chrome, I get

“This site can’t be reached
Check if there is a typo in [stagingurl].
DNS_PROBE_FINISHED_NXDOMAIN”

When I type in the IP of staging, the url bar redirects to [stagingurl] and shows the same.

I’m at a bit of a loss because it by all accounts should be simple, but may have missed something important.

Greetings,

Thank you for asking.

When I try to access your staging.ewagers.com, I got 502 Error returned:

Nevertheless, ewagers.com works fine.

May I ask have you tried checking with the steps from below article?

https://support.cloudflare.com/hc/en-us/articles/115003011431-Troubleshooting-Cloudflare-5XX-errors#502504error

Therefore, have you checked your access or error log at your origin host/server for any clue?

Is your web server for sub-domain listening and working over HTTP or HTTPS? :thinking:
Nevertheless, over what port does it listen/work?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Furthermore, when I check the DNSSEC, I see it’s missing the DS record at your domain registrar and I assume you have got DNSSEC option enabled at Cloudflare dashboard?
Can you try to disable DNSSEC at Cloudflare dashboard for your domain name? :thinking:

Kindly, may I suggest looking into below article for more information about why this error happens and how to trobleshoot:

Hi, thanks for your reply. What makes me think DNS is misconfigured is that I am able to successfully ssh into the IP address but it times out when I try ssh into the url staging.ewagers.co.

I don’t think my server is actually running, which is why you see bad gateway. I am trying to restart it with a new deployment but the deployment times out just like SSH, so those may be related.

Example: ssh [email protected] works, but ssh [email protected] times out.

However, ping staging.ewagers.co gives back responses.

I triple checked my security groups on AWS and I am allowing all traffic, so ssh should be fine. I am wondering why ssh to my server IP works but not to the corresponding url? And why does ping work for url but not ssh?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.