Is it possible AT&T is blocking certain Cloudflare IPs?

So I have been using Cloudflare for last few weeks, with success, running a small personal website that only I access outside of my network. It’s encrypted with SSL certs, using Caddy to automatically take care of it (in tandem with Cloudflare), all working fine until today.

I cannot access the website on my own network anymore. I figured it has something to do with my router, but I haven’t touched that at all and everything seems to be working fine.

Then I tried accessing the website from outside my network and to my surprise, it worked perfectly fine. So I digged deeper, and found it that while pinging my domain, it redirected to a cloudflare IP (after doing an IP lookup) and that ping consistently fails. Even when I directly ping the cloudflare server IP, all packets are lost and it fails every time. Whenever I connect with a VPN or outside my network, it works fine.

Is it possible that my ISP has decided to block a Cloudflare IP for some reason? What else could cause the pinging of that Cloudflare server IP to fail on my network, but return fine using a VPN?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.