Is it cloudflare configuration or something else?

Hi. I’m currently using woocommerce to sell digital products through my website. I found out that users weren’t able to check out a product using a free coupon when they place an order. So when I deactivated all the plugins as well as the theme to check for a conflict, I found out that it was WP Mail SMTP plugin that was causing the problem. Checking out issue was solved was the WP Mail SMTP plugin was deactivated. However, other issues arose such as email not getting sent to the user when the user wishes to reset a password. I’m also using woocommerce my account page here,

How can I fix both the checkout issue and the email delivery issue without having to deactivate the WP Mail SMTP plugin? Would it happen to be a configuration issue on Cloudflare? Can you help me? Thank you.

It sure doesn’t sound like Cloudflare:

With WP Mail SMTP active, you can send mail, but not use the coupon.
Without WP Mail SMTP active, you can not send mail, but can use the coupon.

Try a different SMTP plugin. I use the one you were using, so I can’t recommend any others.

I used WP Mail SMTP before switching to Cloudflare and I had no issues with sending and receiving emails. So I’m wondering if I configured the setting correctly. Can you check to see if the setting has been configured correctly on WP Mail SMTP? Here’s a screenshot.

Thank you.

I’m pretty sure I’ve looked at that domain before for a Cloudflare issue. Weird. I can’t find it in Search.

The “mail” hostname in DNS is set to Proxy (:orange:). It needs to be set to :grey: (DNS Only) in order to allow email connections.

I see. I tried to change it to DNS Only, but I don’t see any option for DNS Only after clicking the Proxied under Proxy Status. Can you help me? Thanks.

Here’s a screenshot. I tried with the edit but to no avail.

In Edit mode, clicking on the :orange: or :grey: will switch its status.

1 Like

I edited again and it worked. Can you check to see that everything is correct?

Screenshot