Is Calgary online yet?


#1

March 29th Cloudflare’s blog mentioned there is now a presence in Calgary but a week later, I’m still not seeing any traffic go there.

From a Shaw cable modem:

[~]curl --head https://cloudflare.com | find "CF-RAY"
CF-RAY: 4078a7e9dcb33b0e-YVR
[~]dig @1.1.1.1 id.server CH TXT +short
"yvr01"

I tested TELUS DSL (local telco) yesterday and didn’t get to Calgary either, nor does my Rogers mobile phone. I’ve been out a bit over the last week and tried from a few random public hotspots and so far I’ve gotten responses from YVR (Vancouver), SEA (Seattle), YYZ (Edmonton), and once somewhere down in Texas, so depending on the network it seems like I hit anywhere surrounding Calgary, but never Calgary.

Is there any traffic hitting the Calgary site yet? Routing can certainly take a bit of time to settle sometimes, but I’d expect to see some sign within a week on at least one of the major carriers.


#2

Great question… I don’t know the answer, but I’ve asked internally. If you have any traceroutes or other network info which might help us determine which subnets you’re on feel free to add them. :slight_smile:


#3

Sure, can do. Here’s what I can do from where I’m standing right now. I grabbed the IP, traceroute and a dig. I have previously confirmed at these sites that with curl --head that CF-RAY indicates the same city as @1.1.1.1’s id.server, but I can cross check locations as I go, if you would like.

Current IP Address: 184.68.216.134

traceroute to 1.1.1.1 (1.1.1.1)…

0 70.77.0.1 29.17ms 14.72ms 10.7ms

1 rc3so-be116-1.cg.shawcable.net (64.59.134.129) 13.35ms 22.61ms 14.77ms

2 rc3no-hge0-19-0-1.cg.shawcable.net (66.163.71.117) 14.39ms 18.79ms 16.41ms

3 rc1st-be11-1.vc.shawcable.net (66.163.72.70) 24.77ms 24.31ms 26.44ms

4 vanix.cloudflare.com (206.41.104.52) 24.17ms 23.89ms 27.17ms

5 1dot1dot1dot1.cloudflare-dns.com (1.1.1.1) 25.18ms 27.84ms 34.52ms

ANSWER SECTION

id.server. 0 CH TXT “yvr01”

Current IP address: 70.77.16.122

(Trace route blocked)

ANSWER SECTION

id.server. 0 CH TXT “yvr01”

Current IP address: 24.114.27.195

Note: 1.1.1.1 is unreachable from this network.

traceroute to 1.0.0.1 (1.0.0.1)…

0 - * * *

1 192.168.111.2 125.66ms 238.27ms

1 - *

2 10.128.102.13 97.14ms 42.13ms 39.96ms

3 24.156.157.149 65.64ms 54.4ms 39.73ms

4 24.156.147.61 90.85ms 42.11ms 39.85ms

5 24.156.146.54 83.37ms 46.21ms 39.94ms

6 24.156.157.121 78.8ms 49.88ms 55.78ms

7 24.156.147.62 57.64ms 58.29ms 43.61ms

8 24.156.147.57 54.91ms 42.1ms 51.94ms

9 209.148.227.254 150.89ms 49.92ms 44.09ms

10 108.162.243.249 80.16ms 71.22ms 43.47ms

11 1dot1dot1dot1.cloudflare-dns.com (1.0.0.1) 50.74ms 38.78ms 44.11ms

ANSWER SECTION

id.server. 0 CH TXT “sea01”

Current IP Address: 2605:8d80:4e2:4ee4:70ce:fe49:9e89:c336

traceroute to 2606:4700:4700::1111 (1.0.0.1)…

0 - * * *

1 fdfe:dcba:9876:115a::2 181.82ms 125.19ms 191.83ms

2 2607:f230:0:218::1 42.76ms 50.12ms

2 2607:f230:0:217::1 50.27ms

3 2607:f230:0:20e::1 76.63ms 37.74ms

3 2607:f230:0:20d::1 69.9ms

4 2607:f798:10:1e3::241:5614:7053 73.31ms 74.08ms

4 2607:f798:10:900f::241:5614:7061 67.89ms

5 2607:f798:10:2e8::2091:4823:2002 117.03ms

5 2607:f798:10:1e3::241:5614:7053 58.11ms 81.94ms

6 2607:f798:10:354::1 147.69ms

6 2607:f798:10:2e8::2091:4823:2002 102.09ms

6 2607:f798:10:295::2 101.3ms

7 2607:f798:10:30b::1 89.13ms 102.3ms

7 2607:f798:14:2b::2 118.26ms

8 2400:cb00:29:1024::6ca2:f036 98.53ms

8 2400:cb00:29:1024::6ca2:f0c6 97.6ms

8 2607:f798:14:2b::2 98.64ms

ANSWER SECTION

id.server. 0 CH TXT “yyz01”

Let me know if any alternate information would be useful. I’ll try to avoid repeating providers, but I am testing IPv4 and IPv6 separately as they could be routed differently.


#4

Now on cloudflarestatus.com, it says that Calgary (and a bunch of other POPs) are re-routed. Scrolling down says Resolved, so I’m not sure which to believe.


#5

Interesting point. I’ll wait until that clears.

I think it will show green even when POPs are down as long as traffic is routed to a working site. Confirmation from Cloudflare would be appreciated just to know for the future.


#6

Since Calgary reports as being online again (and has for some hours) here’s two more from TELUS.

Current IP Address: 2001:56a:7501:d200:20b1:b5e6:6674:43f9

traceroute to 2606:4700:4700::1111 ((null))…

Loss% Sent Last Avg Best Worst Stddev

1 node-1w7jr9ya3bd6l29mtqvazzlg0.ipv6.telus.net (2001:56a:7501:d200:aa39:44ff:fedf:3250) 0.00% 2 13.45 11.32 9.20 13.45 3.01

2 clgrabbjre01.bb.telus.com (2001:56a:2:f::2b) 0.00% 2 44.20 32.37 20.53 44.20 16.74

3 sttlwawbbr03.bb.telus.com (2001:568:1::50d) 0.00% 2 43.18 48.64 43.18 54.10 7.72

4 v6-six.as13335.com (2001:504:16::3417) 0.00% 2 357.31 201.96 46.62 357.31 219.69

5 2400:cb00:28:1024::a29e:6858 0.00% 1 58.42 58.42 58.42 58.42 0.00

5 2400:cb00:28:1024::a29e:6804 0.00% 1 40.71 40.71 40.71 40.71 0.00

ANSWER SECTION

id.server. 0 CH TXT “sea01”

Current IP address: 199.126.38.167

traceroute to 1.1.1.1 (1.1.1.1)…

0 192.168.1.254 7.65ms 77.14ms 6.63ms

1 10.139.164.1 11.32ms 61.26ms 16.24ms

2 154.11.12.201 81.42ms 84.97ms 62.42ms

3 six.as13335.com (206.81.81.10) 33.42ms 49.53ms 33.9ms

4 1dot1dot1dot1.cloudflare-dns.com (1.1.1.1) 26.83ms 39.54ms 40.93ms

ANSWER SECTION

id.server. 0 CH TXT “sea01”

I retested a couple previous ones just to confirm nothing has changed since I might have initially tested when Calgary was offline. No change.


#7

Current IP Address: 66.97.182.85

traceroute to 1.1.1.1 (1.1.1.1)…

0 - * * *

1 192.168.1.1 31.17ms 5.9ms 3.35ms

2 lns2.qzwestcom.com (192.153.186.4) 36.26ms 38.48ms 38.61ms

3 bgp1.qzwestcom.com (192.153.186.1) 67.55ms 36.13ms 38.84ms

4 bgp2.qzwestcom.com (192.153.186.2) 39.05ms 38.25ms 37.33ms

5 204.101.5.205 61.2ms 36.98ms 39.17ms

6 core2-vancouver_9-1-0.net.bell.ca (64.230.123.250) 45.11ms 44.92ms 43.95ms

7 tcore4-seattle_hundredgige0-5-0-0.net.bell.ca (64.230.79.94) 50.65ms 44.61ms 41.93ms

8 bx4-seattle_ae3.net.bell.ca (64.230.125.233) 40.04ms 39.55ms 40.55ms

9 six.as13335.com (206.81.81.10) 56.03ms 40.1ms 40.06ms

10 1dot1dot1dot1.cloudflare-dns.com (1.1.1.1) 40.06ms 43.1ms 40.55ms

ANSWER SECTION

id.server. 0 CH TXT “yyz01”

cf-ray: 4092633008d15546-ORD

I checked this twice, the second after disabling cellular just to ensure I was using wifi. Weird. I’ve been randomly checking with curl, but it’s harder to copy/paste from iOS. This is the first time I got different sites from id.server and curl.


#8

Were you able to get any information? I’m still unable to find any network in Calgary that actuall connects to Cloudflare’s fabled Calgary site.


#9

Originally I asked about the PoP itself… no answer. So I filed a ticket with out networking team on the results you found. Will update when we know more.


#10

Did you get any response?

There is one change from my perspective, today:
;; ANSWER SECTION:
id.server. 0 CH TXT “yvr01

curl https://www.cloudflare.com/cdn-cgi/trace
fl=29f16
h=www.cloudflare.com
ip=2001:470:b37f:10:4029:c7f5:9b4f:5f20
ts=1524087245.111
visit_scheme=https
uag=curl/7.55.1
colo=YYZ
spdy=off
http=http/1.1
loc=CA

So it seems like DNS and HTTPS services are now coming from two different locations, neither of them from the new YYC (Calgary) location.


#11

Yeah sorry forgot to update.

Vancouver is the closest place we peer with Shaw, they don’t peer on any exchanges in Calgary.


#12

I could have sworn they did (but of course, things change too).

But not Shaw, TELUS, Rogers (wireless), or any of the other handful of places I’ve tried? It doesn’t seem like Cloudflare YYC has a whole lot of use if none of the consumer/SMB ISPs actually use it.

I did find one network where I hit Cloudflare Calgary (the health network that services hospitals and some other facilities).

Ahh well, nothing you can do on your end. I’ll poke some contacts at Shaw and see if I can find out why Shaw isn’t peering on local exchanges in their headquarter’s city.

Appreciated!


#13

Useful link someone passed to me: https://peeringdb.com/net/317


#14

Thanks! Okay, that clarifies what I was remembering.

One of YYCIX locations has a full partnership with Shaw, yet they apparently don’t participate in their own facility even though they sell services there.


#15

This topic was automatically closed after 14 days. New replies are no longer allowed.