Is a rule possible to ignore cookie in header and cache page?

Hi all,

I am using Siteground with Cloudflare AP0

All my product pages seem to have the woocommerce_recently_viewed in the header of the page, which is stopping all product pages being cached.

Have worked out that the JetWooBuilder plugin is causing this function to get activated even though I am not using their recently viewed option in any of their widgets.

Is there any way around this with cloudlfare?

Below are the headers causing the issue:

HTTP/1.1 200 OK =>
Server => nginx
Date => Wed, 29 Dec 2021 08:58:32 GMT
Content-Type => text/html; charset=UTF-8
Connection => close
Vary => Accept-Encoding
X-Cache-Enabled => True
Link => ; rel=“”, ; rel=“alternate”; type=“application/json”, ; rel=shortlink
Set-Cookie => woocommerce_recently_viewed=7457; path=/
X-Httpd => 1
Host-Header => 6b7412fb82ca5edfd0917e3957f05d89
X-Proxy-Cache => MISS
X-Proxy-Cache-Info => d NC:000000 UP:SKIP_CACHE_SET_COOKIE


Sorry, but Set-Cookie is a response header from the server.

I also don’t think you want to cache anything where this cookie is involved because Recently Viewed is custom content for that specific visitor. It would be a bad user experience for someone to see another person’s Recently Viewed list.

1 Like

ok, thanks for replying

Have just been given some code by Crocoblocks to stop the JetWoo plugin from setting this cookie in the first place, so looking good now!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.