IPv6 to IPv4

Greetings. We have installed all the “Restoring Original Visitor IPs” mods at both the host server level and the client level for resolving the original visitor IP issue, but we are still only getting half of the IP addresses coming up as IPv4, but some still show as IPv6.

Before we switched over to using Cloudflare we had everything showing as IPv4 on our site, which is how we prefer it. Is there anything else we can do to get all IP addresses of site visitors and incoming site mails to show visitor IPs as IPv4 again please?

Also, small housekeeping issue: The information on the link below from Cloudflare support on how to fix this issue with phpBB websites is out of date:

It gives the following link, which is not the right solution anymore and is now an outdated thread on the phpBB forums: phpbb[DOT]com/community/viewtopic.php?p=13936406#p13936406

The Cloudflare support page should be updated to provide this link for phpBB sites instead: https://www.phpbb.com/customise/db/extension/cloudflare_ip/


https://dash.cloudflare.com/?to=/:account/:zone/network#pseudo_ipv4 should be on “Overwrite”

Wonderful. Thank you. I have enabled it. Hopefully that fixes the issue.

Unfortunately, we discovered another IP issue now. Our site receives a lot of site mails via the contact page on our site. Part of the metadata that the contact form provides is the senders IP address. About 15% of the IP addresses that we have been receiving site mails appear to be nonexistent IP’s. Following is a handful of the nonexistent IP addresses that we have received within site mails over the last five days.

It would be great if we could understand why this is happening and how we can prevent it because the senders IP information is often very useful for us.

Thank you for any thoughts which you might be able to offer us on how to fix this issue.

Because these requests came from IPv6 addresses. When you choose pseudo IPv4 addresses, Cloudflare naturally cannot provide real IPv4 addresses but tries to transform the IP address into something which syntactically is a valid IPv4 address. If you want real addresses which are not IPv6 though you will have to upgrade to a paid plan where you can disable IPv6 altogether.

Thank you and understood. I have now changed the setting to Add Header instead of Replace Header

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.