IPS change -> IPv6 only. Home server isn't reachable from IPv4 clients anymore

What is the name of the domain?


What is the issue you’re encountering

IPv6 clients can connect, IPv4 only clients can’t anymore

What steps have you taken to resolve the issue?

I’ve found a service at https://v4-frontend.netiter.com/ where I basically just put their IPv4 as an A record on my domain and it will somehow act as an intermediate, enabling the connection for IPv4 clients. Does cloudflare have a similar, inbuilt solution to this problem? Or an alternative way of solving this situation?

What feature, service or problem is this related to?

DNS records

Welcome to the Cloudflare Community. :logodrop:

When hostnames are :orange: proxied, they can be reached via either the IPv4 or IPv6 addresses of the Cloudflare proxy regardless of whether the origin is accessible via both. Proxied :orange: hostnames will publish A and AAAA records even if only one is available on the origin.

Be aware that the Cloudflare proxy is for serving websites and is not a general purpose IPv4 to IPv6 gateway. Some use cases may either not function, like SSH, email, etc, while others, like running a media server or file server can result in a ToS violation.

1 Like

Thanks for your fast reply!

Yeah, I thought that’s what would/should happen if I proxied the AAAA record.
Now I have gone back and forth between:

a) (unproxied) AAAA record with my IPv6; (unproxied) A record with from https://v4-frontend.netiter.com/ ;
b) (proxied) AAAA record with my IPv6;

And no matter how often I repeat this, configuration a) lets me access the little whoami service no problem, b) times out, using 3 different browsers on 2 differnt devices, on two different networks.

I’m not really sure why this would happen, I turned off SSL and it’s just a simple whoami docker container with an exposed port, no reverse proxy, no certificates, nothing else inbetween. That’s all for later, I just want to get basic connectability now.

The regular Cloudflare proxy only works for HTTP/HTTPS traffic, and only on a short list of supported ports. If your service isn’t HTTP or isn’t on one of those ports then it won’t work.

Cloudflare does offer Spectrum, but it is absurdly expensive and probably not suitable because of the cost.

If you need other protocols or ports, Cloudflare’s ipv4-to-ipv6 feature may not be the solution you need. But, if ports (rather than protocols) are the issue, you can use an Origin Rule to forward connections to any port you need. So instead of connecting to foo.example.com:4321, you could make foo.example.com forward to port 4321 without needing to enter it when you connect. This is available even on a free plan.


OH that was IT!
I was trying to access a port, that wasn’t supported by the proxy, so there you go, problem solved.
Just goes to show that by simplifying things you can sometimes end up making them much more difficult :sweat_smile:
Thanks for your help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.