Ipfs static site redirect http->https

Hi

I have a site notbadnet.com using IPFS/IPNS and I found from the posts here that I need to contact support or post here to get it so that Ipfs static site will redirect http β†’ https

Could I have that added, please.

I’ve escalated this to see if someone can take care of it for you.

1 Like

Given your configuration, you should be able to use Always use HTTPS option.

You should also consider registering for the private beta of the IPFS gateway, which would allow you to have a better control and long term support.

2 Likes

Hi

Thank you for your reply, I have had the always use HTTPS active for 2 months but HTTP refuses to redirect to HTTPS

I signed up for the beta last week, I am not sure why the always use HTTPS option is not working but any help would be greatly appreciated.

Thanks in advance

I have applied to the beta again as the email I used to fill in the form was not the one on the account so entered the details again

HI thanks for the initial reply, the DNS still doesn’t redirect HTTP β†’ HTTPS could you advise what I should do next, I signed up for the beta 5 days as mentioned by @thibault1 but nothing has changed, what is the turnaround time for the beta?

Thanks in advance

The redirection from HTTP to HTTPS should be on for the host you mention.

The beta has not yet been enabled on the associated account.

Thank you for the response, HTTP to HTTPS is on the account but not currently working, I am assuming I would need to have the beta enabled before it works?

Thanks

Can you provide a curl command showing there are no redirection.
From my end, there appear to be one

$ curl -I 'http://notbadnet.com/'
HTTP/1.1 301 Moved Permanently
Location: https://notbadnet.com/

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.