IP of A record not updating

I migrated a WP site to a different server.
I updated the A record with new IP ( but the domain is still pointing to the old server.
Both servers have the same files except for (http://onixaudio.us/test.html) that is only on the new server

I recommend that you toggle that DNS entry to :grey: DNS Only and give it five minutes to take effect before you test your website.

I did that and that actually worked (pointed to the new IP) but it messed up the SSL certificates.
Why the proxy is not refreshing to the new IP?

When a record is :orange: Proxied, the public IP address will not change, even if the behind-the-scenes IP address changes.

I understand That I see Clodflare IP when proxied
The behind the scenes is the one not changing.
I have the proxy disabled now

When you toggled it to :grey:, that was a test of the behind the scenes IP address.

How about this: From the Overview page, how about putting it into Development mode and see if that shows the content you want?

I tried that and also Purge Cache.
Nothing changed

You currently have a security issue.

1 Like

Ok, well. I’m trying to fix the self signed certificate on the new server but what brings me here is that when the proxy is enabled, it points back to the old previous IP.
I dont think it is realted to the Auto SSL of the server…

Thank you for your help

Anyone can tell me why if i enable the proxy it reverts to the previous server?

This should answer your question:

No Jake.
Activating the proxy shows the old server (On a different IP). Is like the old IP is cached on the proxy(wired)
I’m not talking about a ping request to the domain. I know those will always show Clodflare DNSs

You said a different server. Is this with the same host?

Ok, Lets start all over

I migrated a WP site to a different server.

Site was at bluehost IP
Cloudflare was pointing A record to that IP and proxied

I move it to different NEW host IP
I updated the IP in the A record but it continue showing the site in bluehost (this never happened to e before and I migrated many sites) It usually updates in 1-2 minutes.
After hours waiting I end up removing the proxy, and then it showed the NEW server.

I waited more and enable proxy: Again it showed back the old Bluehost site. (The IP is no loger in the DNS list of cloudflare)

So. The problem is: When I enable proxy I get an old IP that is no longer listed on the DNS list.

I do see that you have server-side caching, but it’s unlikely that would have carried over from the old server.

By any chance, are you using a Bluehost feature that adds Cloudflare to your site?

Yes, but I set cloudflare on my account on top of bluehost before making the transfer.
Do I need to release it from bluehost? how?

Interesting, you think there is another account from Bluehost that is conflicting?

That’s what usually causes such behavior. A :orange: Proxied hostname has assigned third party (such as Bluehost) settings that you’re stuck with until they release them.

If you click on a third party integration, you’d have to ask that host to completely remove that integration from their Cloudflare setup.

Ok, I will try that. How I will know when the changes are made?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.