IP exposed while pinging with site name

Hi, I recently moved my domain to cloudflare and set up DNS records accordingly. When I ping from cmd line, it shows server ip address instead of CF ip address. My other domains work as expected.

Tried all options that I’m aware of but nothing worked.

I could see amalia.ns.cloudflare.com and konnor.ns.cloudflare.com as nameservers at cloudflare site setup but when I do nslookup I get tori.ns.cloudflare.com and eric.ns.cloudflare.com

Non-authoritative answer:
nammaapp.com nameserver = tori.ns.cloudflare.com
nammaapp.com nameserver = eric.ns.cloudflare.com

Thanks,

Make sure your record is proxied :orange: otherwise if it isn’t :grey: it will just go right to your server

1 Like

Yes it is. any changes required? ping shows as follows

Looking good to me:

$ ping nammaapp.com
PING nammaapp.com(2606:4700:3030::6815:4f7e (2606:4700:3030::6815:4f7e)) 56 data bytes
64 bytes from 2606:4700:3030::6815:4f7e (2606:4700:3030::6815:4f7e): icmp_seq=1 ttl=56 time=21.9 ms
64 bytes from 2606:4700:3030::6815:4f7e (2606:4700:3030::6815:4f7e): icmp_seq=2 ttl=56 time=21.9 ms

$ iplookup 2606:4700:3030::6815:4f7e
{
  "ip": "2606:4700:3030::6815:4f7e",
  "city": "San Francisco",
  "region": "California",
  "country": "US",
  "loc": "37.7621,-122.3971",
  "org": "AS13335 Cloudflare, Inc.",
  "postal": "94107",
  "timezone": "America/Los_Angeles",
}

Your local DNS is likely just not updated yet

You currently have a security issue.