IP connection issue

Hi,

I have connection issues to one of my site with certain resolved IPs. You get different IPs from different DNS providers depending on your location. That’s totally fine, but I experience that certain IPs don’t work.

nslookup 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

Non-authoritative answer:
Name:
Addresses: 2a06:98c1:3121::c
2a06:98c1:3120::c
188.114.96.12
188.114.97.12

nslookup 8.8.8.8
Server: dns.google
Address: 8.8.8.8

Non-authoritative answer:
Name:
Addresses: 2a06:98c1:3121::d
2a06:98c1:3120::d
188.114.97.13
188.114.96.13

With the .12 IPs I get:

curl -vvv

  • Trying 188.114.97.12:80…
  • connect to 188.114.97.12 port 80 failed: Timed out
  • Trying 188.114.96.12:80…
  • connect to 188.114.96.12 port 80 failed: Timed out
  • Failed to connect to port 80 after 42111 ms: Timed out
  • Closing connection 0
    curl: (28) Failed to connect to port 80 after 42111 ms: Timed out

With the .13 IPs the site is working as expected (connection is ok, http → https words, etc).
Never experienced that behavior before in the last years.

[sorry, here with proper formatting]

Hi,

I have connection issues to one of my site with certain resolved IPs. You get different IPs from different DNS providers depending on your location. That’s totally fine, but I experience that certain IPs don’t work.

>nslookup [DOMAIN] 1.1.1.1
Server:  one.one.one.one
Address:  1.1.1.1

Non-authoritative answer:
Name:    [DOMAIN]
Addresses:  2a06:98c1:3121::c
          2a06:98c1:3120::c
          188.114.96.12
          188.114.97.12
>nslookup [DOMAIN] 8.8.8.8
Server:  dns.google
Address:  8.8.8.8

Non-authoritative answer:
Name:    [DOMAIN]
Addresses:  2a06:98c1:3121::d
          2a06:98c1:3120::d
          188.114.97.13
          188.114.96.13

With the .12 IPs (from 1.1.1.1) I get:

>curl [DOMAIN] -vvv
*   Trying 188.114.97.12:80...
* connect to 188.114.97.12 port 80 failed: Timed out
*   Trying 188.114.96.12:80...
* connect to 188.114.96.12 port 80 failed: Timed out
* Failed to connect to [DOMAIN] port 80 after 42111 ms: Timed out
* Closing connection 0
curl: (28) Failed to connect to [DOMAIN] port 80 after 42111 ms: Timed out

With the .13 IPs (from 8.8.8.8) the site is working as expected (connection is ok, http → https works, etc).
Never experienced that behavior before in the last years.

Your issue could be related to following thread:

Do you happen to have proxy mode activated on this site of yours?

Thanks for pointing me to that post, I linked my issue there. My problem is, that I can’t (easily) disable proxy mode, because there is an AWS infrastructure behind CF and I currently have no certificate issue service in place there (for https).

You’re welcome.

I am still waiting for someone with an enterprise plan to call the emergency hotline
or for someone with a Business or Pro account to open a ticket about it
since Cloudflare did not give a statement
and doesn’t acknowledge this problem on their status page after 12h hours.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.