IP change seems to have worked but still seeing old website

THANK YOU! Delighted to say it is resolved.
Just to let you know: After all that was done, I was getting SSL error (ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome, SSL_ERROR_NO_CYPHER_OVERLAP on Firefox).
I turned off proxied for a while and then everything seemed to work.
Before that I also added a rule to Cloudflare that I don’t know if I needed or not, just in case (saw it on a YT video) for http://domain.com/
Always use HTTPS
Do you think that is good to have there or redundant?